Microsoft 365 planning repos tournant

Diane26

XLDnaute Nouveau
Bonjour à tous,

je sèche un peu quant au tableau des repos tournants de mes équipes.
J'ai une équipe de 40 personnes qui travaille comme suit :

Semaine du L au V avec repos le S et le D
Semaine du L au S avec 1 repos tournant (L, M, M, J, V) dans la semaine + repos le D

Sachant que les repos se composent comme suit :
Semaine 1 : Samedi dimanche
Semaine 2 : lundi dimanche
Semaine 3 : Samedi dimanche
Semaine 4 : mardi dimanche
Semaine 5 : samedi dimanche
Semaine 6 : mercredi dimanche
etc...

est-ce que je peux créer une série pour chaque agent ? Si oui, comment ?

Merci d'avance,
 
Solution
Bonjour,

Planning de repos tournant une semaine sur 2 pour une année complète.
en premier avoir la fréquence : (à partir d'une formule de Dranreb)
VB:
=SI(EST.IMPAIR($B3);SI(JOURSEM($A3;2)>5;"";MOD(ENT(MOD(ENT(($A3))+1/5;52+5/28));5)+1);"")
puis renseigner le planning:
=SI(ET(EST.PAIR($B3);JOURSEM($A3;2)>5);"R";SI(ET(EST.IMPAIR($B3);JOURSEM($A3;2)=7);"R";SI(JOURSEM($A3;2)=INDEX($C$3:$C$380;$B3*7-D$1);"R";"")))
Voir le fichier

piga25

XLDnaute Barbatruc
Bonjour,

Planning de repos tournant une semaine sur 2 pour une année complète.
en premier avoir la fréquence : (à partir d'une formule de Dranreb)
VB:
=SI(EST.IMPAIR($B3);SI(JOURSEM($A3;2)>5;"";MOD(ENT(MOD(ENT(($A3))+1/5;52+5/28));5)+1);"")
puis renseigner le planning:
=SI(ET(EST.PAIR($B3);JOURSEM($A3;2)>5);"R";SI(ET(EST.IMPAIR($B3);JOURSEM($A3;2)=7);"R";SI(JOURSEM($A3;2)=INDEX($C$3:$C$380;$B3*7-D$1);"R";"")))
Voir le fichier
 

Pièces jointes

  • Planning repos tournant.xlsx
    77.6 KB · Affichages: 5

Statistiques des forums

Discussions
313 328
Messages
2 097 214
Membres
106 879
dernier inscrit
Peaulittic