Pb de formule SOMME DECALER

Tibao2b

XLDnaute Nouveau
Bonjour à tous,

J'ai un beug que je n'arrive à résoudre.
La formule suivante :

{=SOMMEPROD((DECALER($J$2;1;;NBVAL($A:$A)-1)>J30)*(DECALER($E$2;1;;NBVAL($A:$A)-1)=E30)*(DECALER($F$2;1;;NBVAL($A:$A)-1)=F30))+1}

qui fonctionnait très bien avec excel 2003 plante dans excel 2010 et me met #N/A.
Je vous dépose un petit fichier excel pour mieux comprendre.
D'avance merci pour votre aide.
 

Pièces jointes

  • Classeur1.xlsx
    11.3 KB · Affichages: 53
  • Classeur1.xlsx
    11.3 KB · Affichages: 59
  • Classeur1.xlsx
    11.3 KB · Affichages: 53

Fred0o

XLDnaute Barbatruc
Re : Pb de formule SOMME DECALER

Bonjour Tibao2b,

Avec un fichier ne contenant pas de formule et une formule donnée faisant référence à J30, E30, F30 qui sont vides dans le fichier fourni + une formule faisant référence au nombre de valeurs dans la colonne A qui est aussi vide dans le fichier fourni, difficile de t'aider.

Il serait également bien que tu nous dise ce que doit retourner la formule pour chacune des lignes d'exemple.

A+
 

R@chid

XLDnaute Barbatruc
Re : Pb de formule SOMME DECALER

Bonjour @ tous,
Salut Fred0o,
Si j'ai bien compris, en K3,

Correction de ta formule,
Code:
=SOMMEPROD((DECALER($J$2;1;;NB($J:$J))>J3)*(DECALER($E$2;1;;NB($J:$J))=E3)*(DECALER($F$2;1;;NB($J:$J))=F3))+1

une autre simple,
Code:
=NB.SI.ENS(E:E;E3;F:F;F3;J:J;">"&J3)+1

@ valider tout simplement par une Simple Entree
@ tirer vers le bas
@ +
 
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
312 875
Messages
2 093 148
Membres
105 641
dernier inscrit
Naoel