Moyenne sans prendre en compte les 0?

jeromegmc

XLDnaute Occasionnel
Bonjour à tous,

Je cherche un formule excel pour faire une moyenne de cellules non adjacentes et cela en ne prenant pas en compte les zéros, j'ai essayé ça mais ça ne marche pas:


=MOYENNE(SI(B5=0,'',B5),SI(B15=0,'',B15),SI(B25=0,'',B25))

j'obtiens #VALEUR!

Un petit coup de main, merci


A+
 
L

laM

Guest
Bonjour à tous

On peut aussi n'utiliser que des sommes :
=SOMME(B2;D1;C3;D4;E5)
et on copie la formule en ajoutant des >0 pour compter les cellules ni vides, ni nulles
=SOMME(B2>0;D1>0;C3>0;D4>0;E5>0)

si on regroupe le bazar, la moyenne correspond à
=SOMME(B2;D1;C3;D4;E5) / SOMME(B2>0;D1>0;C3>0;D4>0;E5>0)

Au revoir, à bientôt
 

Discussions similaires

Statistiques des forums

Discussions
313 283
Messages
2 096 813
Membres
106 752
dernier inscrit
Tahiri1976