XL 2021 Jour férié dans Planning

Retraite

XLDnaute Nouveau
Bonjour,

J'ai fais un double planning selon besoin et je voudrais que s'affiche les jours fériés (feuille Paramètres)
Que ce soit avec Index ou Recherchev, j'arrive pas à afficher le jour férié. Test en D65 ou C67, pourquoi ?

Merci d'avance
 

Pièces jointes

  • Planning - Campagne.xlsx
    73.7 KB · Affichages: 7

mapomme

XLDnaute Barbatruc
Supporter XLD
Bonjour @Retraite :),

Essayer : =SIERREUR(RECHERCHEV(C65;E63:F73;2;FAUX);"")

On recherche la correspondance exacte (d'où la présence du 4ème paramètre à FAUX) de la date C65 :
  • si la date est trouvée, on retourne l'intitulé correspondant (renvoyé par Recherchev)
  • si la date est absente, Recherchev renvoie une erreur et on retourne la chaine vide ""
 
Dernière édition:

JHA

XLDnaute Barbatruc
Bonjour à tous,

Tu recherches du texte dans une plage numérique.
A essayer
VB:
=SIERREUR(RECHERCHEV(INDEX(Parametres!$B$7:$B$59;EQUIV('Le Fieu'!$A$2;Parametres!$A$7:$A$59));Parametres!$E$63:$F$73;2;FAUX);"")

JHA
 

Pièces jointes

  • Planning - Campagne.xlsx
    74.3 KB · Affichages: 8

JHA

XLDnaute Barbatruc
Bonjour à tous,

Peut-être:
VB:
=SIERREUR(INDEX(Parametres!$F$63:$F$73;EQUIV(DATE(DROITE($B$2;4);1;3)-JOURSEM(DATE(DROITE($B$2;4);1;3))-5+(7*$A$2);Parametres!$E$63:$E$73;0));"")

JHA
 

Pièces jointes

  • Planning - Campagne (1).xlsx
    74.2 KB · Affichages: 7

Discussions similaires

Statistiques des forums

Discussions
313 274
Messages
2 096 754
Membres
106 739
dernier inscrit
jcdu16