XL 2019 Je galère pour une formule de dépassement de date

Sebreizh

XLDnaute Nouveau
Bonjour à tous,

Je galère pour une formule que je veux mettre en place sur une feuille Excel.

C'est à priori très simple mais malgré mes nombreuses recherches ... j'y arrive pas.

J'ai une colonne I avec plusieurs lignes de date. Je veux que dans la colonne K, la formule affiche EN RETARD si la date est dépassée et OK si la date n'est pas dépassée.

Ci dessous une copie d'écran d'une partie de mon tableau et une formule que j'avais trouvé. Cette formule me donne toujours le même résultat même si la date n'est pas dépassée ... je me creuse la tête mais je m'en sors pas :-(

Je vous mets également le fichier en pièce jointe.

Si vous avez la solution et surtout l'explication pour que je comprenne pourquoi ma formule ne fonctionne pas je vous en serai très reconnaissant.

Merci de votre aide et bonne journée à tous,
1609325985267.png
 

Pièces jointes

  • Fichier Suivi prêt.xlsx
    19.6 KB · Affichages: 20

Dranreb

XLDnaute Barbatruc
Bonjour.
Non.
1609332804131.png

Le format de cellule n'est même pas un format de date, d'ailleurs, et de toute façon, le type de donnée de sa valeur n'est pas Date.
Remarque: Sur ce site, je me sert très souvent de ce dialogue perso. S'il vous intéresse faites le moi savoir.
 
Dernière édition:

Staple1600

XLDnaute Barbatruc
Bonjour Dranreb

=>Sebreizh
De breton à breton
formates tes dates comme des dates!
;)

Et tu verras que ta formule et ces deux autres
(oui j'ai du temps à perdre ;))
fonctionnent parfaitement
=SI(A1<AUJOURDHUI();"EN RETARD";"OK")
ou
=CHOISIR(1+(A1<AUJOURDHUI());"OK";"EN RETARD")
ou
=REPT("EN RETARD";A1<AUJOURDHUI())&REPT("OK";A1>=AUJOURDHUI())

=>Dranreb
Pourquoi ne pas proposer ton complément dans le section Téléchargements?
(comme tu l'as fait pour tes autres productions de haute tenue soit dit en passant)
 

Sebreizh

XLDnaute Nouveau
Bonjour Dranreb

=>Sebreizh
De breton à breton
formates tes dates comme des dates!
;)

Et tu verras que ta formule et ces deux autres
(oui j'ai du temps à perdre ;))
fonctionnent parfaitement
=SI(A1<AUJOURDHUI();"EN RETARD";"OK")
ou
=CHOISIR(1+(A1<AUJOURDHUI());"OK";"EN RETARD")
ou
=REPT("EN RETARD";A1<AUJOURDHUI())&REPT("OK";A1>=AUJOURDHUI())

=>Dranreb
Pourquoi ne pas proposer ton complément dans le section Téléchargements?
(comme tu l'as fait pour tes autres productions de haute tenue soit dit en passant)

Et oui ... malheureusement breton expatrié mais bien breton :)
En effet la formule fonctionne en mettant un format de date 20/11/20 mais du coup comment puis-je "formater" toute la colonne ? en faisant clic droit, format cellule, date ... le contenu ne change pas
1609344403445.png
 

Pièces jointes

  • 1609344199941.png
    1609344199941.png
    32 KB · Affichages: 21

Sebreizh

XLDnaute Nouveau
Bonjour.
Non.
Regarde la pièce jointe 1090191
Le format de cellule n'est même pas un format de date, d'ailleurs, et de toute façon, le type de donnée de sa valeur n'est pas Date.
Remarque: Sur ce site, je me sert très souvent de ce dialogue perso. S'il vous intéresse faites le moi savoir.
bonjour, comment puis je convertir ce "texte" en date sachant que comme je le mentionne dans un post le clic droit format cellule, date ne change rien ?

Merci de votre temps
 

Discussions similaires

Statistiques des forums

Discussions
303 642
Messages
2 012 839
Membres
219 433
dernier inscrit
neotraxo