Inverser date

Rick@

XLDnaute Occasionnel
Bonjour,

J'ai beau chercher je ne trouve pas une solution simple genre formule =inverse... pour inverser les dates d'un fichier.

Voir fichier joint.

Merci.
 

Pièces jointes

  • Inverser dates.xls
    22 KB · Affichages: 29
  • Inverser dates.xls
    22 KB · Affichages: 31
  • Inverser dates.xls
    22 KB · Affichages: 32

R@chid

XLDnaute Barbatruc
Re : Inverser date

Bonsoir,
pas sur d'avoir bien compris la demande,
si les dates @ inverser sont celles en A2:A4,
et si tu veux dire par inverser changer le "-" par "/",
alors la on peut le faire de plusieurs façons,

sur les mêmes cellules,
tu tapes 1 dans une cellule quelconque, et tu fais un copier
tu sélectionnes A2:A4 et Collage Spécial/Multiplication
Format de cellules/Personnalisée /et tu te sert de cette format : JJ/mm/aaaa

si tu veux le faire sur autres cellules,
en C2,
Code:
=1*A2
en modifiant le format de cellule en : JJ/mm/aaaa

ou,
Code:
=SUBSTITUE(A2;"-";"/")
en gardant les dates en format texte

Amicalement

Edit : Salut Jocelyn :eek:
 

job75

XLDnaute Barbatruc
Re : Inverser date

Bonsoir à tous,

Eventuellement en C2 :

Code:
=TEXTE(--A2;"aaa-mm-jj")
Fonctionne même si l'on a revalidé A2 pour obtenir une "vraie" date.

Fichier joint.

A+
 

Pièces jointes

  • Inverser dates(1).xls
    25.5 KB · Affichages: 32

job75

XLDnaute Barbatruc
Re : Inverser date

Bonjour Rick@,

Cette histoire d'effet "miroir" me plaît assez.

1) Sélectionner B2 et définir le nom TestFormat par la formule :

Code:
=STXT(LIRE.CELLULE(53;Feuil1!A2);5;1)="-"
LIRE.CELLULE est une fonction macro Excel 4.0.

2) Formule en B2 à tirer vers la droite et vers le bas :

Code:
=TEXTE(--A2;SI(TestFormat;"jj-mm-aaaa";"aaaa-mm-jj"))
Fichier (2).

A+
 

Pièces jointes

  • Inverser dates(2).xls
    21 KB · Affichages: 28
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
312 938
Messages
2 093 776
Membres
105 819
dernier inscrit
julien.aupecle