XL 2016 Inverser concatener une cellule

Agecanonix35400

XLDnaute Nouveau
Bonjour à tous

Je n'arrive pas à trouver une formule pour inverser la fonction concatener. Normal puisqu'elle n'existe pas🤣
Dans l'exemple ci joint j'ai mis ce que je reçois des fournisseurs.
Il me faudrait une formule pour "déconcatener" dans les colonnes B,C,D et E
En effet passer par "données" et "convertir" ne fonctionne pas correctement et j'ai des données à rajouter au fur et à mesure.
C'est fastidieux de le faire manuellement.
Il s'agit de données de prise en charge, début, fin de courses.
ex :
DEB : 16:01PEC : 16:32ARR : 17:05FIN : 17:05

Il faudrait que j'ai en colonne B: DEB : 16:01
en colonne C: PEC : 16:30 ect...

merci pour votre aide
 

Pièces jointes

  • Exemple.xlsx
    155 KB · Affichages: 7

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Agecanonix,
D'après ce que j'ai compris, un essai en PJ avec une simple formule :
VB:
=SIERREUR(STXT(Tableau2[[#Cette ligne];[Horaires Saisis]];CHERCHE(Tableau2[[#En-têtes];[DEB]];Tableau2[[#Cette ligne];[Horaires Saisis]]);12);"")
Mais avec les données rangées dans l'ordre DEB - PEC - ARR - FIN.
Un ordre autre compliquerait beaucoup la formule, à mon avis.
 

Pièces jointes

  • Exemple (2).xlsx
    746.3 KB · Affichages: 5

Gégé-45550

XLDnaute Accro
Bonjour à tous

Je n'arrive pas à trouver une formule pour inverser la fonction concatener. Normal puisqu'elle n'existe pas🤣
Dans l'exemple ci joint j'ai mis ce que je reçois des fournisseurs.
Il me faudrait une formule pour "déconcatener" dans les colonnes B,C,D et E
En effet passer par "données" et "convertir" ne fonctionne pas correctement et j'ai des données à rajouter au fur et à mesure.
C'est fastidieux de le faire manuellement.
Il s'agit de données de prise en charge, début, fin de courses.
ex :
DEB : 16:01PEC : 16:32ARR : 17:05FIN : 17:05

Il faudrait que j'ai en colonne B: DEB : 16:01
en colonne C: PEC : 16:30 ect...

merci pour votre aide
Bonjour,
en B2, à recopier vers le bas :
VB:
=GAUCHE(A2;SIERREUR(TROUVE("PEC";Tableau2[@[Horaires Saisis]]);0))
en C2, à recopier vers le bas :
Code:
=DROITE(A2;NBCAR(A2) + 1 - SIERREUR(TROUVE("PEC";Tableau2[@[Horaires Saisis]]);0))

[EDIT]
après réflexion, voir PJ.
[/EDIT]
Cordialement,
 

Pièces jointes

  • Exemple.xlsx
    599.9 KB · Affichages: 2
Dernière édition:

Membres actuellement en ligne

Statistiques des forums

Discussions
313 276
Messages
2 096 760
Membres
106 744
dernier inscrit
sshkm16