Formule pour erreur #N/A

Cazinos

XLDnaute Occasionnel
Bonjour le forum,

parfois il arrive que ma formule recherchev renvoie #N/A
pour régler le problème il suffit que je convertisse la formule "GAUCHE(A3;15) en "cnum" et sa fonctionne.

J'aimerai pouvoir modifier cette formule afin d'éviter de saisir "cnum" aux cellules qui renvoies l'erreur

exemple : si(numérique; cnum(GAUCHE(A3;15));GAUCHE(A3;15))
)

merci

formule en L1 =RECHERCHEV(M3;BDD;2;FAUX) résultat #N/A
formule en m1 =GAUCHE(A3;15)résultat 444440290644211
 

Brigitte

XLDnaute Barbatruc
Re : Formule pour erreur #N/A

Bonsoir,

Avec par exemple ESTERREUR ou ESTNA :

=si(esterreur(RECHERCHEV(M3;BDD;2;FAUX));"";RECHERCHEV(M3;BDD;2;FAUX))

ou

=si(estna(RECHERCHEV(M3;BDD;2;FAUX));"";RECHERCHEV(M3;BDD;2;FAUX))

idem pour la deuxième :

=si(esterreur(GAUCHE(A3;15));"";GAUCHE(A3;15))

ou

=si(estna(GAUCHE(A3;15));"";GAUCHE(A3;15))
 
Dernière édition:

Brigitte

XLDnaute Barbatruc
Re : Formule pour erreur #N/A

Bonsoir,

J'avais négligé un bout de ta question, alors si tu essayais ceci :

=si(estna(GAUCHE(A3;15));cnum(gauche(A3;15);GAUCHE(A3;15))

ou bien ce que tu veux au début :

=si(estna(telle cellule);cnum(gauche(A3;15);GAUCHE(A3;15))
 

Brigitte

XLDnaute Barbatruc
Re : Formule pour erreur #N/A

Re,


Je viens d'essayer un truc tout bête :

=SI(ESTNA(C7);"faux";"juste")

et ca marche... Donc faut perséverer, doit manquer qqchse, déjà si tu as copié/collé ma formule, xld met parfois des espaces et il me semble en voir un, ce ne serait pas ca le problème ?

=si(estna(GAUCHE(A247;15));cnum(GAUCHE(A247;15);GA UCHE(A247;15)

Dans ce cas, il faut juste l'enlever lorsque tu le colles.

=si(estna(GAUCHE(A247;15));cnum(GAUCHE(A247;15);GAUCHE(A247;15)
 
Dernière édition:

jeanpierre

Nous a quitté
Repose en paix
Re : Formule pour erreur #N/A

Bonsoir Cazinos, Bises Brigitte,

Peut-être qu'un petite feuille avec ta problèmatique (et quelques exemples) pourrait aider. (Zippé si tu peux et en bas dans Gérer les pièces jointes/Parcourir, selectionner et Uploader)

A te lire, donc.

Jean-Pierre
 

jeanpierre

Nous a quitté
Repose en paix
Re : Formule pour erreur #N/A

Re,

En L, et en mettant =, on obtient #NOM, normal BDD n'existe pas dans ton fichier.

Pour M, et en mettant aussi =, pas de souci particulier

Lorsque tu dis :

la ligne deux fonctionne avec les formules ci-dessusla ligne trois ne fonctionne pas (saur si on tape "cnum(gauche(A1;15)il faudrait une formule capable de gerer les deux cas

Peux-tu préciser ?. En M pas besoin de CNUM.

En attente, donc.
 

Discussions similaires

Réponses
5
Affichages
705

Statistiques des forums

Discussions
312 147
Messages
2 085 767
Membres
102 968
dernier inscrit
Tmarti