Microsoft 365 NB.Si dans une plage variable combinée avec Equiv

PAPA WALKER

XLDnaute Junior
Bonjour,

Dans une Feuille je souhaite variabiliser une formule avec NB.SI
=NB.SI(BDD!Q5:DP5;"*machaine*")
La formule ci-dessus fonctionne sans souci, mais je souhaiterais que le n° de ligne (ici 5) soit variable en regarde d'une valeur d'une autre cellule ou alors directement dans la même formule, ramener la valeur

Ma cellule qui ramèle le N° de ligne est la suivante en C3:

EQUIV(CNUM(STXT(A1;2;8));BDD!$A$5:$A$5000;0)


je recherche le N° de ligne qui contient une valeur numérique qui correspond à Cnum(stxt(A1;2;8) car en A1, cette valeur est préfiquée et est donc en format txt

Je voulais donc combiner NB.SI et EQUIV mais je n'y arrive pas.
J'ai essayé pas mal de chose du style =NB.SI(&BDDD!Q"&C3&":DP"&C3;"*machaine*")
Mais ça ne marche pas.


Donc si quelqu'un peut m'aider?
Je joins un minuscule fichier

Merci beaucoup par avance
 

Pièces jointes

  • NBSI-EQUIV.xlsx
    10.4 KB · Affichages: 7

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonsoir Papa Walker,
Essayez en B2:
Code:
=NB.SI(INDIRECT("BDD!B"&C1&":AA"&C1);"*EST*")
INDIRECT permet de faire comprendre à XL que la chaine est en fait l'adresse d'une cellule ou plage.
 

CHRIS1945

XLDnaute Occasionnel
Bonsoir,
Est-ce quelque chose ainsi que tu cherches ?
Utilisation des fonctions ADRESSE et INDIRECT pour rendre volatile l'adressage d'une plage.
Si besoin d'explications n'hésites pas à me revenir
Bonne continuation.
Chris
 

Pièces jointes

  • NBSI-EQUIV.xlsx
    9.9 KB · Affichages: 5

PAPA WALKER

XLDnaute Junior
Bonsoir Papa Walker,
Essayez en B2:
Code:
=NB.SI(INDIRECT("BDD!B"&C1&":AA"&C1);"*EST*")
INDIRECT permet de faire comprendre à XL que la chaine est en fait l'adresse d'une cellule ou plage.
Merci pour ce retour et je vais essayer ça immédiatement :)
 

Discussions similaires

Membres actuellement en ligne

Statistiques des forums

Discussions
302 236
Messages
2 001 687
Membres
215 256
dernier inscrit
Adso