XL pour MAC RechercheV ne fonctionne pas

mysterinc

XLDnaute Nouveau
Bonjour les copains,
Je dois traduire du contenu en me basant sur une base de données existante.
Pour une raison que j'ignore la recherche V, semble ne pas fonctionner.
J'ai tapé cette formule : =RECHERCHEV(C2;Feuil2!$A$1:$D$3;4;FAUX)
Pourtant j'ai l'erreur N/A en résultat.

Alors qu'avec un commande/CTRL+F je retrouve la formule.
J'ai essayé sur Google et Gsheet. Je n'ai pas l'impression qu'il y ait d'espaces supplémentaires.
Pourriez-vous m'aiguiller pour m'aider à résoudre ce problème, svp ?
D'avance, je vous remercie beaucoup,
 

Pièces jointes

  • test.xlsx
    10.3 KB · Affichages: 6

Phil69970

XLDnaute Barbatruc
Bonjour @mysterinc
Edit : Bonjour @ALS35

Voir l'aide de rechercheV:

1710314776267.png


=RECHERCHEV(C2;Feuil2!$C$1:$D$3;2;FAUX)

Bonne lecture
 

Pyros2536

XLDnaute Nouveau
Bonjour les copains,
Je dois traduire du contenu en me basant sur une base de données existante.
Pour une raison que j'ignore la recherche V, semble ne pas fonctionner.
J'ai tapé cette formule : =RECHERCHEV(C2;Feuil2!$A$1:$D$3;4;FAUX)
Pourtant j'ai l'erreur N/A en résultat.

Alors qu'avec un commande/CTRL+F je retrouve la formule.
J'ai essayé sur Google et Gsheet. Je n'ai pas l'impression qu'il y ait d'espaces supplémentaires.
Pourriez-vous m'aiguiller pour m'aider à résoudre ce problème, svp ?
D'avance, je vous remercie beaucoup,
Bonsoir Mysteric
J'ai repris ton fichier et te propose deux solutions: soit la fonction recherche_x si ta version XL l'accepte, soit la traditionelle recherchev. Les deux fonctionnent. Probablement un pb de tableau de recherche non trié par ordre croissant.
Pour Recherche_X tu peux télécharger le complément excel sur le site Excel Pratique
Pyros
 

Pièces jointes

  • test.xlsx
    14.4 KB · Affichages: 5

mysterinc

XLDnaute Nouveau
Merci les copains. En sélectionnant la colonne A, la rechercherV a fonctionné.
Mais je ne comprends pas pourquoi il refuse de rechercher à partir de la colonne C, même si les termes et mises en formes sont identiques entre les 2 cellules.

Belle journée à tous,
 

Phil69970

XLDnaute Barbatruc
Bonjour à tous

@Pyros2536
En proposant d'installer un complément plus ou moins exotique il faut préciser à l'utilisateur que son complément fonctionnera uniquement sur son PC et si son fichier est pour un autre PC il faudra installé le dit complément sur l'autre PC.

Et en cas de problème il n'y aura pas grand monde pour te répondre ici car pour faire un test il faudra installé le complément sur son PC et pas sur que beaucoup de contributeur le fasse !!! o_O

De plus à quoi cela sert de conseiller d'installer un complément quand une simple rechercheV disponible sur toutes les versions d'excel fait ce que demande l'utilisateur !!! :oops:
 

Discussions similaires

Statistiques des forums

Discussions
313 266
Messages
2 096 669
Membres
106 705
dernier inscrit
break