Formule pour date sur 3 ou 4 chiffres

MJ13

XLDnaute Barbatruc
Bonjour à tous,

Je cherche une formule pour calculer la date sachant que j'ai par exemple des dates sous la forme:

3005
306

Or je voudrais avoir 30/05/2008 et 03/06/2008 car le premier 0 est supprimé pour les dates inférieures au 10.

Merci d'avance aux super formulistes.

C'est pour ma future version pour faire ses comptes encore plus automatique (mais bon ce n'est que le début et c'est pas gagné).
 

wilfried_42

XLDnaute Barbatruc
Re : Formule pour date sur 3 ou 4 chiffres

bonjour

essaye cela avec le nombre en A1

Code:
=date(annee(aujourdhui());droite(A1;2)*1;gauche(texte(A1;"0000");2)*1)

edit : manquait une parenthese

re-edit : Bonjour abcd :) Tibo :) Jocelyn :)
 
Dernière édition:

MJ13

XLDnaute Barbatruc
Re : Formule pour date sur 3 ou 4 chiffres

Bonjour Wilfried.

Merci beaucoup. Aussi à l'aise en formule qu'en VBA, c'est le top d'XLD.

Je crois que j'aurais mis beaucoup plus de temps à trouver (en fait cela ne fonctionnait pas au début mais j'ai décomposé et c'est OK).

Bonne journée.
 

abcd

XLDnaute Barbatruc
Re : Formule pour date sur 3 ou 4 chiffres

Bonjour,

A essayer :
=DATE(2008;MOD(A1;100);GAUCHE(A1;NBCAR(A1)-2))

abcd

Edition :
Un peu plus court : =DATE(2008;MOD(A1;100);ENT(A1/100))

Edition 2 :
Salut Tibo, j'ai pas copié !
 
Dernière édition:

Jocelyn

XLDnaute Barbatruc
Re : Formule pour date sur 3 ou 4 chiffres

Bonjour le Forum,
Bonjour MJ13, wilfried_42 :), abcd :), Tibo:),

Principalement pour saluer mes camarades et pour faire l'inverse d'eux c'est a dire non pas trouver la formule la plus courte et la plus simple mais la plus longue et allambiquée une autre solution

=SI(NBCAR(A1)<4;DATEVAL(GAUCHE(A1;2)&"/"&TEXTE(DROITE(A1);"00")&"/"&ANNEE(AUJOURDHUI()));DATEVAL(GAUCHE(A1;2)&"/"&TEXTE(DROITE(A1;2);"00")&"/"&ANNEE(AUJOURDHUI())))

Jocelyn
 

Discussions similaires

Statistiques des forums

Discussions
312 896
Messages
2 093 387
Membres
105 716
dernier inscrit
jrmdprt