XL 2010 excel 2010 sur 5 colonnes: calculer le stock pouvant etre consommé en tenant compte de la date et du code de plusieurs articles différents

stivus bricsus

XLDnaute Nouveau
Bonjour à tous,
ca fait déjà 3semaines que je recherche une association de formule sur excel 2010 me permettant d'évaluer un stock.
En effet je dispose d'une liste de produits identifiables par le code article, la description article.
Pour chaque article nous pouvons avoir des dates de péremption différentes et pour chaque date de péremption des quantités.
A chaque article correspond une consommation mensuelle.
Je veux avoir la quantité qui peut etre consommer pour chaque article tenant compte de ces différentes dates de péremption et de la consommation mensuelle.

Par exemple, on peut avoir du 100 paracetamol avec 3 dates et les qtités respectives suivantes :

qté : 20 de 30/10/2021,

qtité 30 de 30/12/2021

et qtité 50 de 30/04/2022.

Avec une consommation moyenne par mois de 5.

Pour la premiere date on ne pourra consommer avant peremption que 7,5 paracetamol sur 20 donc stock viable=7,5 (car avant peremption il reste 1,5 mois)

Pour la deuxieme date d’expiration, ca consommation débutera après celle de la premiere date d’expiration donc à partir du 1er/11/2021 (donc on a 2 mois comme nombre de mois de consommation), stock viable=2*5=10.

Pour la troisieme date d’expiration sa consommation débutera après celle de la deuxieme date, donc 1er/01/2022 (donc le nombre de mois de consommation est de 4 mois), stock viable=4*5=20

Donc total stock viable du paracetamol=37,5 au lieu de 100

Merci d'avance les champions
 

Pièces jointes

  • inventaire et date d'expiration.xlsx
    13.7 KB · Affichages: 37

stivus bricsus

XLDnaute Nouveau
Bonjour @stivus bricsus ,@Wayki

Une proposition de formule a mettre en F2 et a tirer vers le bas :

Code:
=SIERREUR(SI((C2-AUJOURDHUI())/30>D2/E2;D2;E2*(C2-AUJOURDHUI())/30);"")
Merci tonton, pour la formule, mais j'avais déjà une formule pareil pour avoir le stock viable.
En effet, ta formule ca donne l'avant dernière colonne mais la réponse exacte c'est la dernière colone.
codedescriptionexpirationqtecmmstock viable sans tenir compte de la conso précédentestock viable tenant compte de la conso précédente
dp001para
30/10/2021​
20​
5​
6,50​
6,5​
dp001para
30/12/2021​
30​
5​
16,67​
10​
dp001para
30/04/2022​
50​
5​
36,83​
20​

Parce que pour la consommation, la première date d'expiration (30/10/2021) sera d'abord consmmée (6,5): dans ce cas là la formule est exacte,
Mais lorsqu'on a des dates d'expiration différentes, les consommations se font une date après l'autre pas au meme moment.
Ainsi dès le 31/10/2021, la deuxième date d'expiration commence à etre consommé jusqu'au 30/12/2021. Donc sa consommation réelle est de 10 au lieu de 16,67.
Pour la troisième date, elle commence à etre consommé le 31/12/2021 pour une consommation réelle de 20 au lieu de 36,83.

C'est ce décalage de consommation tenant compte des dates de pérempion par item qui rend l'encodage de la formule difficile.

De mon coté, je poursuis mes recherches de la formule idéale
En attente d'une solution de votre part

merci
 

Statistiques des forums

Discussions
312 803
Messages
2 092 250
Membres
105 316
dernier inscrit
cyrille225