Formule avec SI

  • Initiateur de la discussion Natacha
  • Date de début
N

Natacha

Guest
Bonjour, je voudrais écrire une formule, dont voici l'idée :


-----je simplifie car elle est tres longue---------- (avec plein des 'si')

=SI(a1-a2<0;'ok';écrire le résultat de a1-a2)


si j'écris la formule ainsi Si(a1-a2<0;'ok';a1-a2) -> j'ai un message d'erreur. ('la formule contient une erreur')

est ce parce que la formule est trop longue ?

ya til une solution pour ne pas écrire la formule une deuxieme fois ?

->> l'idée serait : Si(a1-a2<0;'ok';sinon donner le résultat) pour ne pas avoir à écrire Si(a1-a2<0;'ok';a1-a2)


j'espere que vous avez compris,

merci pour vos idées, Natacha
 
N

Natasha

Guest
Re,

J'envoie mon tableau excel, j'ai mis des indications directement sur le document

Merci pour vos conseils ,

@++ Nat [file name=Classeur2_20050825170549.zip size=4701]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/Classeur2_20050825170549.zip[/file]
 

Pièces jointes

  • Classeur2_20050825170549.zip
    4.6 KB · Affichages: 20

Staple1600

XLDnaute Barbatruc
Bonjour

Ya Quelque chose qui me chiffonne
=SI(M4='';SI(AA4='';SI(V4='';NB.JOURS.OUVRES(I4+1;Q4;Fer);NB.JOURS.OUVRES(I4+1;V4;Fer));NB.JOURS.OUVRES(I4+1;AA4;Fer));SI(AA4='';SI(V4='';NB.JOURS.OUVRES(M4+1;Q4;Fer);NB.JOURS.OUVRES(M4+1;V4;Fer));NB.JOURS.OUVRES(M4+1;AA4;Fer)))

déjà pour simpifier

=SI(ET(M4='';AA4='';V4='');.......
cela réduit déjà 3 si en un si

Ce qui me chiffone c'est que tu fais deux fois référence à
AA4
(voir les AA4 mis en gras)

Message édité par: staple1600, à: 25/08/2005 23:17
 
N

Natacha

Guest
Bonsoir,

je suis toujours sur ma formule, et j'essaye de comprendre la simplification de Staple1600 : je n'arrive pas à l'appliquer à ma formule.

Sinon, je ne vois pas non plus pourquoi tu dis que je fais 2 fois référence à AA4...

Pouvez vous m'aider à nouveau ?

Merci,

Nat
 

Staple1600

XLDnaute Barbatruc
Bonsoir

SI(ET(M4='';AA4='';V4='');suite de la formule à mettre ici

Ce début de formule veut dire


Si les cellules M4;AA4;V4 sont vides alors
calcul 1
sinon calcul 2*

Pour être plus clair avec cette formule
=SI(ET(M4='';AA4='';V4='');NB.JOURS.OUVRES(I4+1;Q4;Fer);NB.JOURS.OUVRES(I4+1;V4;Fer))

j'obtiens 11

comme avec la formule de ton classeur exemple

Message édité par: staple1600, à: 25/08/2005 23:32
 
C

Claude

Guest
Bonjour Natacha,Staple

Pour faire marquer OK

Bonne journée

Claude [file name=fonctionsi.zip size=5409]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/fonctionsi.zip[/file]
 

Pièces jointes

  • fonctionsi.zip
    2.9 KB · Affichages: 16
  • fonctionsi.zip
    2.9 KB · Affichages: 27
  • fonctionsi.zip
    2.9 KB · Affichages: 15

Discussions similaires

Réponses
3
Affichages
234
Réponses
6
Affichages
379