XL 2016 RECHERCHV VBA

FURUKU

XLDnaute Nouveau
Bonjour à tous,

J'aurais besoin d'aide pour écrire une recherchv en vba

Ma formule excel est celle ci:

=SIERREUR(RECHERCHEV(B1;Feuille - 1!A$1:AW$108;46;0);"0")

j'ai bien compris que pour faire référence à la feuille -1 on peut utiliser la fonction INDEX
j'aimerais afficher le résultat de la recherche en BG2

j'ai commencé cela dans VBA:

Sub recherchv()
Dim sht As Worksheet, rng As Range
Set sht = Worksheets(ActiveSheet.Index - 1)
Set rng = sht.Range("A1").CurrentRegion
ActiveSheet.Range("BG2").Formula = "=VLOOKUP( LA OU JE SÈCHE)
End Sub


quelqu’un pourrait il m'aider ?
 

Nébuleux

XLDnaute Nouveau
Bonjour à tous,

J'aurais besoin d'aide pour écrire une recherchv en vba

Ma formule excel est celle ci:

=SIERREUR(RECHERCHEV(B1;Feuille - 1!A$1:AW$108;46;0);"0")

j'ai bien compris que pour faire référence à la feuille -1 on peut utiliser la fonction INDEX
j'aimerais afficher le résultat de la recherche en BG2

j'ai commencé cela dans VBA:

Sub recherchv()
Dim sht As Worksheet, rng As Range
Set sht = Worksheets(ActiveSheet.Index - 1)
Set rng = sht.Range("A1").CurrentRegion
ActiveSheet.Range("BG2").Formula = "=VLOOKUP( LA OU JE SÈCHE)
End Sub


quelqu’un pourrait il m'aider ?
Hello mets toi en mode enregistrement de macro tu auras la symntaxe Vba a améliorer ou coriiger eventuellement
 

Discussions similaires

Statistiques des forums

Discussions
313 258
Messages
2 096 614
Membres
106 684
dernier inscrit
ekouepatrick