XL 2019 fonction recherchev

VERDIER

XLDnaute Nouveau
Bonjour à tous,
J'ai bien compris l'utilisation de la fonction RECHERCHEV pour extraire des valeurs d'un tableau.
Toutefois, je souhaiterai extraire plusieurs lignes d'une liste de donnée.
Je m'explique : J'ai un tableau avec plus de 100 lignes débutant par une première colonne contenant un numéro de machine (1; 2; 3; ....). Chacune de ces machines apparait plusieurs fois dans mon tableau. Je souhaiterai à partir d'une liste déroulante de mes machines faire apparaitre SEULEMENT les lignes correspondantes. (La machine figure 25 fois dans mon tableau de donnée, je sélectionne cette machine dans la liste déroulante, j'obtiens une liste de 25 lignes).

En espérant avoir été suffisamment clair dans mon explication....

MERCI

JOEL
 

VERDIER

XLDnaute Nouveau
Par exemple:
Sur l'image jointe, la liste de donnée laisse apparaitre dans la première colonne, 5 fois la machine M1. Je souhaiterai que lorsque je sélectionne M1 dans une liste déroulante SUR UNE AUTRE FEUILLE, je retrouve les cinq lignes correspondantes.
 

Pièces jointes

  • HISTORIQUE.pdf
    14.4 KB · Affichages: 3

sylvanu

XLDnaute Barbatruc
Supporter XLD
Re,
Un fichier pdf n'aide en rien.
Alors un essai en PJ à adapter avec votre fichier XL, avec :
VB:
=SIERREUR(INDEX(essai!A$2:A$1000;PETITE.VALEUR(SI(essai!$A$2:$A$1000=$D$2;LIGNE(INDIRECT("1:"&LIGNES(essai!$A$2:$A$1000))));LIGNES(Feuil1!$1:1)));"")
A valider ou non avec Maj+Ctrl+Entére suivant votre version d' XL.
 

Pièces jointes

  • Verdier.xlsx
    19.2 KB · Affichages: 4