XL 2019 Excel : récupérer données d'un autre onglet et faire une somme cumulée en fonction d'un paramètre

millesetunenuit

XLDnaute Nouveau
Bonsoir à tous,

Je viens ici demander votre aide car je suis désespérée depuis tout cet après-midi à tenter de trouver la solution à mon problème.
J'ai un classeur excel avec deux onglets.
Appellons le premier onglet X et le second Y.
Dans la colonne C de l'onglet X, j'ai besoin de récupérer des données de l'onglet Y en fonction du code identification.
Dans la colonne C, je dois avoir la somme de ligne jusqu'à la date n-1.

Par exemple, pour la cellule C3 je dois avoir 7+7+7+35+7 car la date en B3 est 2028 donc j'ai besoin des donnes jusqu'à 2027.

Je vous remercie infiniment pour votre aide.
J'ai tenté d'utiliser des recherchev,des equiv des index mais impossible de venir à bout.

Bonne soirée à tous :)
 

Pièces jointes

  • IMG_20230309_233255.jpg
    IMG_20230309_233255.jpg
    123.9 KB · Affichages: 19

Dranreb

XLDnaute Barbatruc
Non, 22 c'est en C2. En C3 j'ai 63.
En 'X'!C2, à propager sur 9 lignes :
Code:
=SOMME(DECALER(Y!$B2;0;0;1;$B2-2023))
Pas besoin de rechercher le code: il y a le même dans les deux feuilles en colonne A

S'ils venaient à devenir différents, en 'X'!C2, à propager sur 9 lignes :
Code:
=SOMME(DECALER(Y!$B$2;EQUIV($A2;Y!$A$2:$A$10;0)-1;0;1;$B2-2023))
 
Dernière édition:

millesetunenuit

XLDnaute Nouveau
Merci cela marche.
Je vous remercie :)


Est-ce que vous sauriez comment faire une recherche par rapport au code d'identification.
Car mes codes d'identifications sont ordonnés dans l'exemple mais dans mon cas réel ils ne seront pas ordonnés donc je ne pourrais pas utiliser la formule correctement.
Il faudrait que je fasse une recherche par rapport au code d'identification.
 

millesetunenuit

XLDnaute Nouveau
Désolée, c'est encore moi.

J'ai utilisé la fonction suivante pour récupérer maintenant les données à partir de la date en colonne B.

=SOMME(DECALER(Y!$B$2;EQUIV($A2;Y!$A$2:$A$10;0)-1;0;1;2032-$B2))

Cependant, je n'ai pas les bons résultats.
Pour a je dois avoir la somme des colonnes à partir de 2025 et pour B la somme des colonnes à partir de 2028.
 

Dranreb

XLDnaute Barbatruc
C'est $B2-2023 le nombre de colonnes d'années à couvrir à partir de 2023, pas 2032-$B2 !
Si 2023 peut être changé en une autre année vous pouvez mettre en 'X'!C2, à propager sur 9 lignes :
Code:
=SOMME(DECALER(Y!$B$2;EQUIV($A2;Y!$A$2:$A$10;0)-1;0;1;$B2-Y!$B$1))
 
Dernière édition:

Discussions similaires

Réponses
20
Affichages
351

Statistiques des forums

Discussions
312 803
Messages
2 092 259
Membres
105 319
dernier inscrit
Antho3514