copier plusieurs lignes d'un tableau selon plusieurs conditions

vjoug

XLDnaute Junior
Mesdames, Messieurs les forumeu(s/r)s,

Bien le bonjur en ce dimanche ensoleillé.

Je recherche un technique pour copier plusieurs lignes d'un tableau d'un coup selon plusieurs critères.

Tout d'abord si ma condition est vrai on copie/colle ( 3 cas dissociables)
La ou cela se corse, c'est que la zone a copier dépend d'une variable .

Exemple concret illustré dans mon fichier joint

Si la condition B4 est VRAI on copie/colle la portion du tableau des lignes 13 à 77. On prend alors la valeur en B7 (ex 0600) et la on ne copie que la portion du tableau coontenant en colonne "A" le texte 0600. ( même principe que rechercheV.

Et ceci à trois reprise selon les critères B4,B5,B6 qui sont variables.

J'ai essayé avec RecherhceV, INDEX, des zones avec insertion NOM, EQUIV, forme conditionnelle ... mais rien n'y fait je bloque.
Peut être les matrices mais je n'ai pas encore exploré ce domaine D'excel


Merci par avance de votre aide

Cordialement
 

Pièces jointes

  • copietableausouscondition.xls
    43 KB · Affichages: 229
  • copietableausouscondition.xls
    43 KB · Affichages: 240
  • copietableausouscondition.xls
    43 KB · Affichages: 243

GIBI

XLDnaute Impliqué
Re : copier plusieurs lignes d'un tableau selon plusieurs conditions

Bonjour,

Voici une idée.

pour le premier tableau , définir par exemple visserie (inserer/nom)

=DECALER('Calcul kit visserie'!$A$13:$f$76;1;;NB.SI('Calcul kit visserie'!$A$13:$A$76;Nommenclature!$B$7)-1)

en A36 (à copier sur le tableau)

=SI($B$4=VRAI;INDEX(Visserie;LIGNE($A36)-35;COLONNE(A1)+1);"")

je te laisse développer le sujet


GIBI
 

Pièces jointes

  • copietableausouscondition.xls
    45.5 KB · Affichages: 181
  • copietableausouscondition.xls
    45.5 KB · Affichages: 188
  • copietableausouscondition.xls
    45.5 KB · Affichages: 194

vjoug

XLDnaute Junior
Re : copier plusieurs lignes d'un tableau selon plusieurs conditions

Merci de ta réponse GIBI.

J'ai beau tourner dans tus les sens je n'y arrive pas.Je ne sais toujours pas selectionner par rapport à mon critére DN0600, 0700 ...

Merci tout de même

Cordialement
 

vjoug

XLDnaute Junior
Re : copier plusieurs lignes d'un tableau selon plusieurs conditions

Re salut et salut,

C'est bon j'ai réussi aprés une demi journée de bataille :)

J'ai imbriqué la fnction EQUIV dans la fonction DECALER.
En effet la fnction EQUIV me donne la le nombre de cellule entre mon origine et la cellule trouvée. Il ne reste plus qu'a intégrer le resultat dans l'option DECALER et le tur est joué.
j'ai joint mon fichier pur ce que cela pourrait intéresser.

NB : les cellule doivent impérativmeent être au format TEXTE pur fonctionner avec EQUIV ( en tout cas chez moi)

Cordialement
 

Pièces jointes

  • copietableausouscondition.xls
    46.5 KB · Affichages: 347
  • copietableausouscondition.xls
    46.5 KB · Affichages: 378
  • copietableausouscondition.xls
    46.5 KB · Affichages: 381

Discussions similaires

Réponses
5
Affichages
397
Compte Supprimé 979
C

Statistiques des forums

Discussions
312 800
Messages
2 092 242
Membres
105 305
dernier inscrit
Momone59