XL 2019 sommer les valeurs d'un tableau dans un autre selon critere

JBOBO

XLDnaute Accro
Bonjour à tous,
Tout d'abord, Meilleurs Vœux à tous pour cette nouvelle année. J'ai déserté le forum depuis un moment par manque de temps et j'utilise Excel beaucoup moins qu'avant, et je m'aperçois que j'ai un peu de mal à retrouver le fonctionnement de certaines formules.
Je cherche à recuperer la somme de certaines valeurs d'un tableau pour les afficher dans un autres en fonction de certains critères. je pensais utiliser "sommeprod" mais j'ai un peu beaucoup oublié le fonctionnement de cette formule et toutes ces subtilités. Grâce au fichier joint, pourriez vous m'aider svp ?
Merci d'avance à tous ceux qui me liront et qui se pencheront sur mon problème.
 

Pièces jointes

  • test pour excel download.xlsx
    19.4 KB · Affichages: 4

job75

XLDnaute Barbatruc
Bonsoir JBOBO et mes meilleurs vœux,

Formule en E28 :
Code:
=SOMMEPROD((A6:A16=B24)*(DECALER(B6:B16;;EQUIV(E27&E25;C4:N4&C5:N5;0))=1))
Ah pardon, la somme des "D" donc en E31 :
Code:
=SOMMEPROD((A6:A16=B24)*(DECALER(B6:B16;;EQUIV(E27&E25;C4:N4&C5:N5;0))="D"))
A+
 

Pièces jointes

  • test pour excel download.xlsx
    19.4 KB · Affichages: 3
Dernière édition:

JBOBO

XLDnaute Accro
Bonjour Job75,

Ah ouais, quand meme ! Ce qui me rassure mais qui m'agace également, c'est qu'en voyant la formule, je n'y serais jamais arrivé sans vous.
Bravo et surtout Merci. J'espère maintenant pouvoir appliquer la formule aux fichiers réels.
Je vous tiens au jus .
Encore Merci .
 

Discussions similaires

Statistiques des forums

Discussions
313 296
Messages
2 096 923
Membres
106 788
dernier inscrit
Pragmatis