compter nombre de lot sans les doublons et les cel vide

saoud

XLDnaute Nouveau
bonjour

svp je cherche une formule par la quelle je veut compter le nombre de lot dans un plage , sans compter les doublons et les cellules vides .

cdt.
 

Pièces jointes

  • Classeur1.xlsx
    8.5 KB · Affichages: 35

JBOBO

XLDnaute Accro
Bonjour,

Il y a surement mieux, mais en attendant :
=SOMMEPROD(($C$5:$C$15=$C$5:$C$15)*($C$5:$C$15<>"")*(N(NB.SI($C$5:$C$15;$C$5:$C$15)=1)+(((NB.SI($C$5:$C$15;$C$5:$C$15)=2)/2)+((NB.SI($C$5:$C$15;$C$5:$C$15)=3)/3)+((NB.SI($C$5:$C$15;$C$5:$C$15)=4)/4))+((NB.SI($C$5:$C$15;$C$5:$C$15)=5)/5)))

fonctionne si une valeur n'est pas présente plus de 5 fois, sinon adapter la formule
 

Discussions similaires

Statistiques des forums

Discussions
312 920
Messages
2 093 638
Membres
105 767
dernier inscrit
fthev71