XL 2019 compter les vendredi entre deux dates

LB04

XLDnaute Junior
bonjour, à tous
je soumet un petit problème, qui je pense ce réglera assez vite.
je souhaiterez compter les vendredis et seulement les vendredis entre deux dates.
je vous donne quelques infos : je travail 8h par jour le lundi, mardi, mercredi , jeudi . le vendredi seulement 7h
et quand il m'arrive de travailler le Week end ce sont aussi des journée de 8 h .
il est donc tres difficile d'automatiser un tableau d'heures travailler .
d'avance merci .

Patrick
 

Pièces jointes

  • NBR DE VENDREDI.xlsx
    8.8 KB · Affichages: 3

JHA

XLDnaute Barbatruc
Bonjour à tous,

Formule matricielle à essayer
VB:
=SOMME(--(JOURSEM(LIGNE(INDIRECT(B3&":"&B5));2)=5))
si tu ne veux pas les fériés, tu peux les ajouter à cette formule.
Code:
=NB.JOURS.OUVRES.INTL(B3;B5;"1111011")

JHA
 

Pièces jointes

  • NBR DE VENDREDI.xlsx
    9.2 KB · Affichages: 6

LB04

XLDnaute Junior
super, merci beaucoup JHA .
je ne comprend pas l'histoire des fériés !
bien sur que je les veux .
mais si je les veux pas je les ajoute ?????
 

Pièces jointes

  • NBR DE VENDREDI (1).xlsx
    9.5 KB · Affichages: 4
Dernière édition:

LB04

XLDnaute Junior
re- sur la première feuille tu a c'est formules
=NB.JOURS.OUVRES.INTL(B3;B5;"1111011") en laissant les férié et
=NB.JOURS.OUVRES.INTL(B3;B5;"1111011";Fer) en les retirant
comme j'aime bien comprendre je souhaiterai savoir comment tu rallonge la liste de fierIés ?
Et aussi d'où sort ce chiffre "1111011" et que veut t'il dire ?
merci
 

mapomme

XLDnaute Barbatruc
Supporter XLD
Re,

Fer est tout simplement une plage nommée qui contient la liste des jours fériés.

Si on veut compter tous les vendredis qu'ils soient fériés ou non alors on utilisera :
=NB.JOURS.OUVRES.INTL(B3;B5;"1111011")

Si on veut compter tous les vendredis ordinaires (donc sans les vendredis qui sont aussi fériés) alors on utilisera : =NB.JOURS.OUVRES.INTL(B3;B5;"1111011";Fer)
 
Dernière édition:

LB04

XLDnaute Junior
merci a tous pour votre aide,
donc si je comprend bien chaque "1" correspond a un jour de la semaine,
et le "0" c'est donc le vendredi ?
je peut donc aussi rajouter des date a ma série de jour férié en feuille 2 .
que en insérant une ligne entre les date de férie déjà existante et non a la suite
je vous joint le fichier si vous pouvez me donnez un coup de mains svp
 

Pièces jointes

  • NBR DE VENDREDI bis.xlsx
    10.8 KB · Affichages: 2

JHA

XLDnaute Barbatruc
Bonjour à tous,

Voir fichier pour ajout des congés.
La liste des congés est dynamique (données misent sous mode tableau)
Pas de ligne vide dans le tableau.

JHA
 

Pièces jointes

  • NBR DE VENDREDI bis (1).xlsx
    12.4 KB · Affichages: 5

LB04

XLDnaute Junior
super merci, beaucoup a vous trois
toute c'est solutions ,vont me permettre d'avancer a pas de géant.
et de gagner un temps fou sur ma vérification annuel de pointage
et bien sur je reviendrai vers vous ci je rencontre des difficulté pour automatiser tout ça
encore merci .
 

Discussions similaires

Statistiques des forums

Discussions
313 197
Messages
2 096 109
Membres
106 500
dernier inscrit
mmontagu