Comment automatiser une date dans NB.SI.ENS ?

Widget

XLDnaute Nouveau
Bonjour,

Voici mon problème:

Dans un tableau mis à jour régulièrement par remplacement complet des données car c'est l'extrait au format Excel d'un autre logiciel
La ligne la plus récente est en haut et le sera toujours, donc la dernière date connue également

Je cherche un à faire un calcul sur une année glissante, la dernière date étant donc en haut, il y a un second critère à prendre en compte dans une autre colonne, là c'est du texte
La colonne ou sont inscrite les dates est au format date
La date de l'année glissante pour moi c'est l'adresse de la cellule de la dernière mise à jour, ex B10 - 365 soit =aujourdhui()-365, les deux me conviennent car je ne suis pas à quelques jours.
Mettre la date manuellement dans la formule pour l'année en cours n'est pas un soucis

Ce que j'arrive à faire
=NB.SI.ENS(B10:B100;">=23/05/2016";C10:C100;"*truc*")
Cela fonctionne très bien mais je n'arrive pas à trouver une solution pour automatiser ce changement de date, remplacer ce que l'on vois dans la formule par =aujourdhui()-365 ou B10-365 ne fonctionne pas
Il peut y avoir plusieurs événement rentré le 20/05/2016, dans ce cas, toutes ces dates doivent être incluse
Si cette date n'existe pas (pas d'événement ce jour), alors la date avant ou après fait l'affaire, pas besoin d'être précis.

Ma version d'Excel est la 2007
Par pitié pas de VBA, je n'y comprend rien, pour les formules, je me débrouille avec mon faible niveau, j'apprend

Merci pour l'aide.
 

Pièces jointes

  • Exemple.xlsx
    10.5 KB · Affichages: 40

piga25

XLDnaute Barbatruc
Bonjour,

Remplacer en B6 :
=NB.SI.ENS(B10:B100;">=20/05/2016";C10:C100;"*truc*")
par
=NB.SI.ENS(B10:B100;">"&"="&B4;C10:C100;"*truc*")

et en C6 :
=NB.SI.ENS(B10:B100;">=01/01/2017";C10:C100;"*truc*")
par
=NB.SI.ENS(B10:B100;">"&"="&C4;C10:C100;"*truc*")
 

Statistiques des forums

Discussions
312 816
Messages
2 092 329
Membres
105 367
dernier inscrit
jych