XL 2010 Combiner nb.si contient et recherchev

dimbad

XLDnaute Nouveau
Bonjour,

je tente d’effectuer la recherche suivante mais elle ne fonctionne pas :
=SI(NB.SI(RECHERCHEV(A3;'Reg List'!A:C;3;faux);"*membre*");"ok";"non")

Pouvez-vous m'aider?
Merci bcp d'avance
Marion
 

Theze

XLDnaute Occasionnel
Bonjour,

NB.SI() sert à compter le nombre d'occurrences dans une plage correspondant au critère (ici, le mot "membre") et RECHERCHEV() cherche une valeur dans la première colonne de la plage et renvoi la valeur située sur la même ligne que la valeur trouvée mais dans la colonne indiquée (dans ton cas, la 3 ème colonne de ta plage et donc la colonne C). RECHERCHEV() ne renvoyant pas une plage, NB.SI() retourne une erreur !
Si tu souhaites savoir si dans une des cellules de ta plage se trouve le mot "membre", tu peux tester ceci :
Code:
=SI(NB.SI('Reg List'!C:C;"*membre*")>0;"OK";"NON")
 

Statistiques des forums

Discussions
312 928
Messages
2 093 697
Membres
105 787
dernier inscrit
BABOU79