Microsoft 365 Recherche V avec une partie du texte

nicflix

XLDnaute Nouveau
Bonjour,

Je n'arrive pas à trouver la solution pour compléter ma formule Recherche V suivante : =RECHERCHEV(A2;CATEGORIES!$A$3:$B$10;2;FAUX) afin qu'elle fonctionne en ne cherchant qu'une partie du texte notée dans la cellule A2 et que donc elle me note le bon type de produits.

Actuellement elle fonctionne que si le nom est exactement le même que le libellé ...

Voici le fichier Excel où j'ai un problème.

Pourriez-vous me dire d'où vient mon erreur parce que j'avoue que mon niveau d'Excel ne me permet pas de trouver ?

Merci beaucoup d'avance. :D
 

job75

XLDnaute Barbatruc
Bonjour nicflix, bienvenue sur XLD, salut djidji59430,

Tout ce que j'ai fait c'est d'enlever l'espace superflu en A7 et A8 de la feuille BDD.

On peut utiliser le caractère générique * dans RECHERCHEV :
Code:
=RECHERCHEV("*"&A2&"*";CATEGORIES!$A$3:$B$10;2;FAUX)
Mais de toute façon le texte en A2 doit se trouver intégralement en colonne A de l'autre feuille.

A+
 

Pièces jointes

  • Classeur1.xlsx
    10.5 KB · Affichages: 11

Discussions similaires

Membres actuellement en ligne

Aucun membre en ligne actuellement.

Statistiques des forums

Discussions
312 816
Messages
2 092 361
Membres
105 378
dernier inscrit
y07