XL 2010 changer la couleur des cellule suivant un critère

jeanmi

XLDnaute Occasionnel
Bonjour à tous,

Voici ce que je cherche à faire :

A- Si en C les noms sont identiques, la date de la colonne E passe en rouge si elle n'est pas la même pour le même noms qui est dans la colonne C
B- trouver le nombre de noms qu'il y a en colonne C avec le critère de la colonne L

ci joint un fichier pour mieux comprendre.

une question aussi : y a-t-il des précaution à prendre lorsque l'on utilise des MFC et que l'on déplace copie des cellules dans le fichier ?

Merci pour l'aide.
Cordialement
 

Pièces jointes

  • essai fonction calcul suivant filtre.xlsx
    13.1 KB · Affichages: 3
Dernière édition:

mapomme

XLDnaute Barbatruc
Supporter XLD
Bonjour @jeanmi :),
Si en C les noms sont identiques, la date de la colonne E passe en rouge si elle n'est pas la même pour le même noms qui est dans la colonne C
Voir la MFC sur la plage E3:E14 de formule :
=PETITE.VALEUR(SI(C$3:C$14=C3;E$3:E$14);1)<>GRANDE.VALEUR(SI(C$3:C$14=C3;E$3:E$14);1)

une question aussi : y a-t-il des précaution à prendre lorsque l'on utilise des MFC et que l'on déplace copie des cellules dans le fichier ?
Question imprécise et vague mais, à priori, la réponse est oui.
 

Pièces jointes

  • jeanmi- MFC- v1.xlsx
    14 KB · Affichages: 2

jeanmi

XLDnaute Occasionnel
Bonjour @jeanmi :),

Voir la MFC sur la plage E3:E14 de formule :
=PETITE.VALEUR(SI(C$3:C$14=C3;E$3:E$14);1)<>GRANDE.VALEUR(SI(C$3:C$14=C3;E$3:E$14);1)


Question imprécise et vague mais, à priori, la réponse est oui.
Bonjour @mapomme, à tous

Merci beaucoup pour la rapidité de la réponse qui fonctionne nickel.

Entre temps, moi moins rapide, j'avais rajouté une deuxième demande.

Si vous avez une solution merci d'avance
cordialement
 

jeanmi

XLDnaute Occasionnel
Formule matricielle en M2 à copier vers le bas :

=SOMME(--(FREQUENCE(SI(B$3:B$14=L2;EQUIV(C$3:C$14;C$3:C$14;0));SI(B$3:B$14=L2;EQUIV(C$3:C$14;C$3:C$14;0)))>0))
re bonjour @mapomme à tous

Encore merci c'est nickel.

j'ai transposer la formule du #2 dans mon fichier et ça ne marche pas comme je souhaité, Mais !!!
après analyse j'ai constaté que j'ai oublié de dire qu'il y avait aussi un critère sur la valeur de la cellule B.

es possible ?

Merci d'avance pour la réponse.

cordialement
 

Pièces jointes

  • jeanmi- Compter- v3.xlsx
    13.6 KB · Affichages: 1

Discussions similaires

Statistiques des forums

Discussions
313 195
Messages
2 096 100
Membres
106 495
dernier inscrit
dylan.44