XL 2019 calcul avec tableau Filtré

mathis349

XLDnaute Nouveau
Bonjour a tous,

J'ai créer un fichier d'exemple simple pour expliquer mon problème.

Quand je change le filtre de mon tableau la valeur dans ma formule est modifiée.
quand je trier de A a Z le poids des carottes pour 3 personnes est de 900 grammes mais quand je tri de Z a A le poids est de 3 grammes.
La formule garde la case B2 (Qui est correct pour le tri de A a Z) alors que je voudrais qu'elle suive la ligne des carotte et donc prendre la case B7.
 

Pièces jointes

  • test.xlsx
    10 KB · Affichages: 4

chris

XLDnaute Barbatruc
Bonjour

Cela est normal : B2 est l'adresse de la cellule dont le contenu doit être multiplié par 3.

C'est la logique de tout tableur

Si tu veux des carottes il chercher leur emplacement
VB:
=RECHERCHEV("carotte";Tableau1;2;0)*3
ou , si on indique en F4 l'élément cherché
=RECHERCHEV(F4;Tableau1;2;0)*3
 

Statistiques des forums

Discussions
313 195
Messages
2 096 100
Membres
106 495
dernier inscrit
dylan.44