test date

carinae

XLDnaute Junior
bonjour a tous

je voudrais faire un test sur une date (=SI(OU($C$1<>"";$C$1<>0);$D$1-$C$1;""). J'ai donc 2 cellules au format date
Le probléme est que si je rentre une lettre (en l'occurence x) a la place
d'une date j'ai un retour #valeur!. Normal ! mais je voudrais savoir
s'il y a un moyen de contourner le probléme sachant que je voudrais tout de même pouvoir, si cela est possible, garder ce x afin d'eviter l'affichage de date car si je mets 0 les cellules etant au format date affichent une valeur 00/00/1900.

Si je fais (=SI(OU($C$1<>"";$C$1<>0;$C$1<>x);$D$1-$C$1;"") j'ai un retour
#NOM? Donc comment fair pour prendre en compte correctement ce caratére ?
 

Pièces jointes

  • Classeur1.xls
    13.5 KB · Affichages: 43
  • Classeur1.xls
    13.5 KB · Affichages: 40
  • Classeur1.xls
    13.5 KB · Affichages: 45

Discussions similaires

Statistiques des forums

Discussions
312 145
Messages
2 085 762
Membres
102 966
dernier inscrit
InitialPP