XL 2021 Fonction SIERREUR()

Victor__

XLDnaute Nouveau
Bonjour, j'ai toute une liste de données que je dois analyser. Pour cela j'ai réparti ces données prises minutes par minute en catégorie horaire (Colonne C). En N et O, j'ai crée chaque journée de l'année avec les 24h pour faire des moyennes horaires. Mais j'ai un problème chaque jours, à 19h et 22h, je n'arrive pas à faire mes calculs. Pour contourner cela je souhaiterai appliquer à ces heures les valeurs de l'heure suivante. J'ai donc voulu faire ça avec la fonction SI(), mais je n'y arrive pas.
Formule en P20 : =SIERREUR(MOYENNE.SI.ENS($G$1:$G$422190;$D$2:$D$422191;O20;$E$2:$E$422191;" OK ";$A$2:$A$422191;N20);SI(OU(O20="19:00:00";O20="22:00:00");P21;NA()))
Formule en O20 : =SI(MOD(LIGNE(O20)-LIGNE($O$2); 24) = 0; "01:00:00"; DECALER(O20; -1; 0) + TEMPS(1; 0; 0))

Je souhaiterai que la fonction en P renvoie NA lorsque les premiers critères ne sont pas remplis, sauf dans le cas de 19 et 22h...

Je ne sais pas si c'est clair.

Merci par avance pour votre aide
1702647569377.png
 

TooFatBoy

XLDnaute Barbatruc
Bonjour,

Je ne sais pas si c'est clair.
Pour moi : pas du tout. :(

Un fichier serait mieux qu'une image. ;)

Il vaudrait mieux expliquer ce que tu veux obtenir, plutôt que de dire ce que tu essayes de faire.
Qu'appelles-tu une "catégorie horaire" ? Quelles sont ces catégories ( "matinée", "soirée", autre ?) ?

Est-ce la colonne C qui est en trop, ou les deux colonnes A et B ?
Autrement dit, quelles sont les données originelles ?

Que représente la colonne D ?
 

Victor__

XLDnaute Nouveau
Merci pour ton retour,

Il vaudrait mieux expliquer ce que tu veux obtenir, plutôt que de dire ce que tu essayes de faire.
Qu'appelles-tu une "catégorie horaire" ? Quelles sont ces catégories ( "matinée", "soirée", autre ?) ?
En fait ce sont plutôt des plages horaires d'une heure (entre 00:00:00 et 00:59:59) la catégorie correspondante et 01:00:00 par ex. Ce qui correspond donc à la colonne D.
Cela me permet par après de faire une valeur moyenne par heure de mes données.

La colonne C n'as effectivement pas d'utilité, j'ai obtenu les données avec celle-ci et je n'y ai pas touché.

Ensuite l'objectif est d'obtenir des valeurs moyennes sur mes données mais à condition que le capteur soit "OK", et que les moments où je n'ai pas de données j'ai N/A.

J'ai ajouté un extrait du fichier pour essayer de clarifier la chose, mais je ne peux pas mettre l'original, il est beaucoup trop volumineux.
 

Pièces jointes

  • T304 EXTRAIT-1.xlsx
    18.4 KB · Affichages: 4
Dernière édition:

Gégé-45550

XLDnaute Accro
Merci pour ton retour,


En fait ce sont plutôt des plages horaires d'une heure (entre 00:00:00 et 00:59:59) la catégorie correspondante et 01:00:00 par ex. Ce qui correspond donc à la colonne D.
Cela me permet par après de faire une valeur moyenne par heure de mes données.

La colonne C n'as effectivement pas d'utilité, j'ai obtenu les données avec celle-ci et je n'y ai pas touché.

Ensuite l'objectif est d'obtenir des valeurs moyennes sur mes données mais à condition que le capteur soit "OK", et que les moments où je n'ai pas de données j'ai N/A.

J'ai ajouté un extrait du fichier pour essayer de clarifier la chose, mais je ne peux pas mettre l'original, il est beaucoup trop volumineux.
Bonsoir Victor__, salut l'ami TooFatBoy,
Essayez ceci en P2 ... et suivantes :
VB:
=SIERREUR(MOYENNE.SI.ENS($G$1:$G$422190;$D$2:$D$422191;O2;$E$2:$E$422191;" OK ";$A$2:$A$422191;N2);SI(OU(TEXTE(O2;"#0,#########")=TEXTE(TEMPS(19;0;0);"#0,000000000");TEXTE(O2;"#0,#########")=TEXTE(TEMPS(22;0;0);"#0,000000000"));P3;NA()))
Cordialement,
 

Victor__

XLDnaute Nouveau
Bonsoir Victor__, salut l'ami TooFatBoy,
Essayez ceci en P2 ... et suivantes :
VB:
=SIERREUR(MOYENNE.SI.ENS($G$1:$G$422190;$D$2:$D$422191;O2;$E$2:$E$422191;" OK ";$A$2:$A$422191;N2);SI(OU(TEXTE(O2;"#0,#########")=TEXTE(TEMPS(19;0;0);"#0,000000000");TEXTE(O2;"#0,#########")=TEXTE(TEMPS(22;0;0);"#0,000000000"));P3;NA()))
Cordialement,
Bonjour,

Merci pour votre retour, ça marche parfaitement.

Bonne journée
 

Discussions similaires

Réponses
2
Affichages
245
Réponses
17
Affichages
1 K

Membres actuellement en ligne

Aucun membre en ligne actuellement.

Statistiques des forums

Discussions
313 259
Messages
2 096 618
Membres
106 688
dernier inscrit
Cherif99