XL 2016 formule grande valeur

HES

XLDnaute Nouveau
Bonjour à tous,
C'est ma 1re demande. J'ai bien-sûr parcouru les POST afin de trouver chaussure à mon pied 😉mais sans résultat positif.
J'ai créé un tableau sur 4 colonnes (je mets l'exemple en PJ).
Sur la dernière colonne j'ai fait une formule GRANDE VALEUR afin de ressortir de la colonne C la valeur la plus grande à laquelle je rajoute un coefficient : 90 pour la plus grande valeur, puis 88 pour la 2e, 86 pour la 3e...
Je constate les problèmes suivants :
1/ bien qu'ayant mis dans la formule un résultat à 0 si aucune valeur ne se trouve dans la cellule en colonne C, le résultat n'affiche pas 0
2/ non seulement le résultat n'affiche pas 0, mais en plus il affiche la dernière grande valeur trouvée... si bien que TOUTES les cellules vides affichent cette même valeur (56 dans mon exemple).

Comment permettre de :
  • ne rien mettre dans la colonne "Total avec participation" si il n' a rien dans "Points cumulés" et ne mettre une valeur que si "Points cumulés" est rempli
Je ne sais pas si je suis clair...
Merci
Stéphane
 

Pièces jointes

  • Essai GDE VALEUR.xlsx
    11 KB · Affichages: 4

JHA

XLDnaute Barbatruc
Bonjour à tous,

Un essai avec la fonction rang() et une table de correspondance.

Changement fichier pour ne pas avoir les zéros.
VB:
=SI(OU(ESTVIDE(C2);C2=0);"";INDEX(Table!$B$2:$B$46;EQUIV(RANG($C2;$C$2:$C$44);Table!$A$2:$A$46;0)))


JHA
 

Pièces jointes

  • Essai GDE VALEUR.xlsx
    13.7 KB · Affichages: 0
Dernière édition:

piga25

XLDnaute Barbatruc
Bonjour,
Un autre façon sans utiliser grande valeur
à mettre en D2 et à recopier vers le bas:
VB:
=SI(C2=0;"";INDEX($G$2:$G$44;RANG(C2;$C$2:$C$44;0)))

Puis en G2 mettre 90 et en G3 mettre =G2-2 puis recopier vers le bas.
 

Pièces jointes

  • Essai GDE VALEUR.xlsx
    17.4 KB · Affichages: 2

piga25

XLDnaute Barbatruc
RE,
Autre façon sans colonne supplémentaire :
VB:
=SI(C2=0;"";CHOISIR(RANG(C2;$C$2:$C$44;0);90;88;86;84;82;80;78;76;74;72;70;68;66;64;62;60;58;56;54;52;50;48;44;42;40;38;36;34;32;30;28;26;24;22;20;18;16;14;12;10;8;6;4;2))

Edit: Pas rafraichie njhub
 

Discussions similaires

Réponses
2
Affichages
213

Membres actuellement en ligne

Aucun membre en ligne actuellement.

Statistiques des forums

Discussions
313 271
Messages
2 096 724
Membres
106 720
dernier inscrit
Alain EDZOA