XL 2010 Synthétiser une feuille de données

EXCJPH

XLDnaute Nouveau
Bonjour à tout le forum.
Je reviens vers vous parce que j'ai besoin d'une aide précieuse.
Dans mon classeur SYNTH.xlsx, j'ai une feuille DONNEES et une feuille SYNTHESE.
La feuille SYNTHESE doit reprendre les données de la feuille DONNEES en les restructurant.
La feuille SYNTHESE est déjà construite.
J'ai renseigné manuellement la feuille SYNTHESE avec mes petites croix.
J'y suis également arrivé avec des formules type EQUIV mais c'est fastidieux car il faut reprendre
les formules pour qu'elles pointent au bon endroit...
Je souhaiterais la renseignée mais de manière automatique, et là je coince.
J'imagine que le VBA doit pouvoir avaler cela. Je m'en remets à votre expertise.
Je joins le fichier. (Excel 2007)
Merci à vous de vos proposition. En attendant je cherche aussi la méthodologie.
 

Pièces jointes

  • SYNTH.xlsx
    26.3 KB · Affichages: 9
Solution
Bonsoir Excjph,
Je pense qu'on peut se passer de VBA avec cette formule :
VB:
=SIERREUR(SI(EQUIV(B$1;DECALER(DONNEES!$A:$A;0;EQUIV($A2;DONNEES!$1:$1;0)-1);0)>0;"X";"");"")
Bonsoir sylvanu et au forum.
J'ai testé ta proposition. Que dire à part que c'est parfait ! Ayant bien compris la méthode et la formule, j'ai adapté ta solution à mon fichier que j'ai légèrement modifié.
Merci encore pour ta réactivité et ton esprit de partage.

EXCJPH

XLDnaute Nouveau
Bonsoir Excjph,
Je pense qu'on peut se passer de VBA avec cette formule :
VB:
=SIERREUR(SI(EQUIV(B$1;DECALER(DONNEES!$A:$A;0;EQUIV($A2;DONNEES!$1:$1;0)-1);0)>0;"X";"");"")
Bonsoir sylvanu et au forum.
J'ai testé ta proposition. Que dire à part que c'est parfait ! Ayant bien compris la méthode et la formule, j'ai adapté ta solution à mon fichier que j'ai légèrement modifié.
Merci encore pour ta réactivité et ton esprit de partage.
 

Discussions similaires

Statistiques des forums

Discussions
313 329
Messages
2 097 235
Membres
106 883
dernier inscrit
Papalo