XL 2010 Surlignage de lignes avec mises en forme conditionnelles

marmotte17

XLDnaute Junior
Bonjour à tous,

Je vous sollicite pour un souci que j'ai. Dans mon tableau, le but serait que toutes les dates de la colonne A du même mois se surlignent (avec une mise en forme conditionnelle que j'ai faite en partie) dès que le total de 26,9 est atteint pour le mois. Dans mon exemple, c'est dépassé dès le 6 avril, donc je souhaiterais que les cellules A2 et A3 soient surlignées. Les colonnes sans bordures sont des essais pour les calculs.

J'espère avoir été clair dans mes explications.

Merci d'avance pour votre aide
 

Pièces jointes

  • Salle de Sport.xlsx
    11.2 KB · Affichages: 10
Solution
Re @sylvanu, @marmotte17
Je suis sur mon téléphone mais j'essaie quand même
Ou alors il vous faudrait un tableau par mois, cela permettrait de faire une MFC par mois.
Avec un seul tableau et une seule MFC, on peut traiter les mois et les années.
C'est le pourquoi des fonctions MOIS et ANNEE dans la formule que je propose dans le post#2 :
=SOMMEPROD((MOIS($A2)=MOIS($A$2:$A2))*(ANNEE($A2)=ANNEE($A$2:$A2))*($C$2:$C2))>26,9
Y aurait-il quelque chose qui cloche ?
Dans la pièce jointe il y a des dates en avril et en mai, et ça fonctionne ...
Les dates étant dans l'ordre chronologique...

AtTheOne

XLDnaute Impliqué
Supporter XLD
Bonjour à toutes & à tous,
bonjour @marmotte17
Avec une mise en forme conditionnelle utilisant une formule (avec la plage A2:Axx sélectionnée) mettre la formule : =SOMMEPROD((MOIS($A2)=MOIS($A$2:$A2))*(ANNEE($A2)=ANNEE($A$2:$A2))*($C$2:$C2))>26,9
et choisir le format à appliquer
Attention aux adresses mixtes absolues-relatives
voir la pièce jointe
A bientôt
 

Pièces jointes

  • Salle de Sport.xlsx
    13.1 KB · Affichages: 4

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Marmotte,
un essai en PJ avec en colonne A la MFC :
VB:
=SOMME($C$2:$C2)<=26.5
Merci AtTheOne, nouvel essai avec :
VB:
=ET(SOMME($C$2:$C2)<=26.5;MOIS($A2)=MOIS(AUJOURDHUI()))
En considérant que "est atteint pour le mois." c'est le mois courant.
 

Pièces jointes

  • Salle de Sport V2.xlsx
    10.2 KB · Affichages: 3
Dernière édition:

marmotte17

XLDnaute Junior
Bonjour Sylvanu,

Merci beaucoup pour cette aide. Cela fonctionne très bien pour le mois en cours. C'est déjà cela et cela me suffit. J'aurais voulu savoir s'il était possible que les cellules restent colorées définitivement car je pense que dès que l'on va changer de mois, elles vont redevenir "neutres".

En tout cas, merci infiniment. C'est super.
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Re,
s'il était possible que les cellules restent colorées définitivement
Non, pas dans l'état puisque la MFC répond à cette demande :
dès que le total de 26,9 est atteint pour le mois.
Quelle serait la règle à appliquer ? Juste >=26.5 ? Dans ce cas ce serait indépendant du mois.
Ou alors il vous faudrait un tableau par mois, cela permettrait de faire une MFC par mois. ( voir PJ )

Pour mettre en "Résolu", voir :
 

Pièces jointes

  • Salle de Sport V3.xlsx
    11.5 KB · Affichages: 6
Dernière édition:

AtTheOne

XLDnaute Impliqué
Supporter XLD
Re @sylvanu, @marmotte17
Je suis sur mon téléphone mais j'essaie quand même
Ou alors il vous faudrait un tableau par mois, cela permettrait de faire une MFC par mois.
Avec un seul tableau et une seule MFC, on peut traiter les mois et les années.
C'est le pourquoi des fonctions MOIS et ANNEE dans la formule que je propose dans le post#2 :
=SOMMEPROD((MOIS($A2)=MOIS($A$2:$A2))*(ANNEE($A2)=ANNEE($A$2:$A2))*($C$2:$C2))>26,9
Y aurait-il quelque chose qui cloche ?
Dans la pièce jointe il y a des dates en avril et en mai, et ça fonctionne ...
Les dates étant dans l'ordre chronologique...
 

Discussions similaires

Statistiques des forums

Discussions
308 222
Messages
2 052 608
Membres
233 410
dernier inscrit
josselinch