Microsoft 365 SOMMEPROD Plusieurs colonnes

eric72

XLDnaute Accro
Bonjour à tous,
Je rencontre un souci pour additionner des valeurs en fonction d'un critère ligne et d'un critère colonne qui concerne Plusieurs colonnes, en effet dans l'exemple ci-joint je souhaiterai récupérer la somme des valeurs de la ligne ex: 8:30 pour toutes les colonnes qui contiennent le mot de la cellule ex:B1,mais une nouvelle fois sans succès.
L'un d'entre vous aurait-il la solution.
Merci beaucoup pour votre aide.
Eric
 

Pièces jointes

  • testEDL.xlsm
    30.1 KB · Affichages: 5
Solution
Bonjour Eric,
Un essai en PJ avec :
VB:
=SOMMEPROD((Feuil1!$A$2:$A$1000=$A2)*(GAUCHE(Feuil1!$B$1:$AX$1;5)=GAUCHE(B$1;5));Feuil1!$B$2:Feuil1!$AX$1000)
On peut remplacer les plages par les correspondants dans le tableau, mais je trouve que c'est moins parlant pour un test.

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Eric,
Un essai en PJ avec :
VB:
=SOMMEPROD((Feuil1!$A$2:$A$1000=$A2)*(GAUCHE(Feuil1!$B$1:$AX$1;5)=GAUCHE(B$1;5));Feuil1!$B$2:Feuil1!$AX$1000)
On peut remplacer les plages par les correspondants dans le tableau, mais je trouve que c'est moins parlant pour un test.
 

Pièces jointes

  • testEDL (1).xlsm
    21.8 KB · Affichages: 4

Discussions similaires

Réponses
5
Affichages
312

Statistiques des forums

Discussions
313 277
Messages
2 096 766
Membres
106 746
dernier inscrit
acquabateaux