Somme mensuelle selon une date donnée

SOYA

XLDnaute Occasionnel
Bonjour,

J'ai fait des recherches sur ce forum avec Somme.si, Calcul Date, etc... mais cela me renvoie toujours des dizaines de pages sans entrer dans le vifs du sujet. J'avoue que je n'ai pas eu la patience de me rendre jusqu'à la page 90...

Voici mon problème :

Sur ma feuille 1, j'ai un tableau avec en colonne A des dates, et en colonne D des montants. Sur ma feuille 2, j'ai une date, en l'occurrence le 30 avril 2008, qui est susceptible de changer.

Je voudrais avoir sur ma feuille 2 la formule qui additionne les montants de la colonne D de feuille 1, à condition que la date qui y correspond en A soit du même mois que ma date sur feuille 2.

Soupir...:confused:

Est-ce que c'est assez clair ?

Je vous remercie beaucoup pour votre aide. :)
 

TheLio

XLDnaute Accro
Re : Somme mensuelle selon une date donnée

Hello,

Ce que tu cherches doit ressembler à ceci:

Code:
=SOMMEPROD((MOIS(Feuil1!A2:A29)=MOIS(D5))*(ANNEE(Feuil1!A2:A29)=ANNEE(D5))*Feuil1!D2:D29)
en admettant que la date que tu cherches soit en D5 de la feuille 2

Si tu as un souci, mets nous un bout de fichier en exemple
A++
TheLio
Edit: Bonjour Eric ;)
 

Discussions similaires

Statistiques des forums

Discussions
312 841
Messages
2 092 705
Membres
105 514
dernier inscrit
Hébera