Microsoft 365 SIERREUR et CONCATENER qui ne fonctionne pas

karexcel

XLDnaute Nouveau
Bonjour à tous,
Je sollicite votre aide car je suis coincé depuis plusieurs heures sur une formule et je ne comprends pas pourquoi.

j'ai deux onglets :
Un onglet Saisie
Un onglet "planning"

Dans l'onglet Saisie je vais avoir une imputation par exemple Technicien Paul va 0.5 Chez Madame Durand 0.5 chez Monsieur Dupont le 02/05/2023
Dans l'onglet Saisie j'ai donc 2 lignes
Je souhaite que dans l'onglet planning il n'y ait qu'une ligne le 02/05/2023 avec un concatener "0.5 Durand - 0.5 Dupont"
Ici mon 02/05/2023 est ma cellule E7 , je veux donc que le réasultat soit uniquement en E7

Ma formule qui ne fonctionne pas =SI(ET(A7<>""; D6<>""); SI(LIGNE()=7; SIERREUR(CONCATENER(SI(('Saisie'!$A$1:$A$1000=A6)*('Saisie'!$J$1:$J$1000=D6); 'Saisie'!$H$1:$H$1000&" "&'Saisie'!$F$1:$F$1000); ""))); "")

Avant ca, j'ai essayé des fonctions matricelles qui ne me mettaient pas tous les résultat en D7 mais me generer des resultats en D7 & D8

J'ai mis un fichier en pj si vous pouvez m'aider

Un grand Merci par avance
 

Pièces jointes

  • Exemple concatener planning saisie - Copie.xlsm
    21.6 KB · Affichages: 5

Discussions similaires

Membres actuellement en ligne

Statistiques des forums

Discussions
313 296
Messages
2 096 922
Membres
106 787
dernier inscrit
Rachid ALIOU