XL 2021 RESOLU recherchev vba sur autre feuille

HamoudaBA

XLDnaute Occasionnel
Bonjour le fil,
Je reviens à vous pour m'aider à résoudre mon petit souci.
Je dispose de 2 feuilles "EFFECTIF" et "SAISIE", je cherche à inserer ces formules en VBA
Je cherche en D2 de "SAISIE" à inserer les formules =SI(C2<>"";RECHERCHEV(C2;EFFECTIF!A$2:X$8000;2;FAUX);"")
E2 =SI(C2<>"";RECHERCHEV(C2;EFFECTIF!A$1:X$8000;3;FAUX);"")
F2 =SI(C2<>"";RECHERCHEV(C2;EFFECTIF!A$1:X$8000;4;FAUX);"")
G2 =SI(C2<>"";RECHERCHEV(C2;EFFECTIF!A$1:X$8000;20;FAUX);"")
H2 =SI(C2<>"";RECHERCHEV(C2;EFFECTIF!A$1:X$8735;13;FAUX);"")
en B2 =C2&"_"&NB.SI($C$2:C2;C2)

Je vous remercie.
 

Pièces jointes

  • TEST.xlsx
    16.9 KB · Affichages: 7

job75

XLDnaute Barbatruc
Bonjour HamoudaBA,

Sur une version française :
VB:
Sub a()
Dim f1$, f2$, f3$, f4$, f5$
f1 = "=SI(C2<>"""";RECHERCHEV(C2;EFFECTIF!A$2:X$8000;2;FAUX);"""")"
f2 = "=SI(C2<>"""";RECHERCHEV(C2;EFFECTIF!A$1:X$8000;3;FAUX);"""")"
f3 = "=SI(C2<>"""";RECHERCHEV(C2;EFFECTIF!A$1:X$8000;4;FAUX);"""")"
f4 = "=SI(C2<>"""";RECHERCHEV(C2;EFFECTIF!A$1:X$8000;20;FAUX);"""")"
f5 = "=SI(C2<>"""";RECHERCHEV(C2;EFFECTIF!A$1:X$8735;13;FAUX);"""")"
Sheets("SAISIE").[D2:H2].FormulaLocal = Array(f1, f2, f3, f4, f5)
Sheets("SAISIE").[B2].FormulaLocal = "=C2&""_""&NB.SI($C$2:C2;C2)"
End Sub
A+
 

job75

XLDnaute Barbatruc
Chez moi la macro fonctionne quel que soit l'endroit où on la place.

Les formules sont entrées dans la feuille "SAISIE".

Si on veut étendre les formules jusqu'à la ligne 1000 :
VB:
Sheets("SAISIE").[D2:H1000].FormulaLocal = Array(f1, f2, f3, f4, f5)
Sheets("SAISIE").[B2:B1000].FormulaLocal = "=C2&""_""&NB.SI($C$2:C2;C2)"
 

HamoudaBA

XLDnaute Occasionnel
Bonjour,
Comment peut ne pas avoir les zéros quand on active le macro?
je n'arrive pas à inserer la numérotation automatique par la fonction =SI(C3<>"";MAX($A$1:A2)+1;" ").
Merci
 

Pièces jointes

  • TEST 1.xlsm
    24 KB · Affichages: 2

job75

XLDnaute Barbatruc
Bonjour HamoudaBA, le forum,
VB:
Sub a()
Dim f1$, f2$, f3$, f4$, f5$
f1 = "=SI(C2<>"""";RECHERCHEV(C2;EFFECTIF!A$2:X$8000;2;FAUX);"""")"
f2 = "=SI(C2<>"""";RECHERCHEV(C2;EFFECTIF!A$1:X$8000;3;FAUX);"""")"
f3 = "=SI(C2<>"""";RECHERCHEV(C2;EFFECTIF!A$1:X$8000;4;FAUX);"""")"
f4 = "=SI(C2<>"""";RECHERCHEV(C2;EFFECTIF!A$1:X$8000;20;FAUX);"""")"
f5 = "=SI(C2<>"""";RECHERCHEV(C2;EFFECTIF!A$1:X$8735;13;FAUX);"""")"
Sheets("SAISIE").[D2:H20].FormulaLocal = Array(f1, f2, f3, f4, f5)
Sheets("SAISIE").[A2:A20].FormulaLocal = "=SI(C2<>"""";MAX(A$1:A1)+1;"""")"
Sheets("SAISIE").[B2:B20].FormulaLocal = "=SI(C2<>"""";C2&""_""&NB.SI(C$2:C2;C2);"""")"
End Sub
Centrez la colonne A.

A+
 

HamoudaBA

XLDnaute Occasionnel
Bonjour Job75,
Le fichier contient des données très personnelles et confidentielles que je ne peut guerre publier.
je me trouve bloqué avec cette erreur.
j'ai recopier mes données sur le même fichier "Test" avec copier coller jusqu'à là tout va bien, une fois j'ai commencé la saisie manuelle que j'ai trouvé ce problème.
Merci
 

Statistiques des forums

Discussions
313 286
Messages
2 096 823
Membres
106 756
dernier inscrit
ghileshndl