Microsoft 365 Récupérer date de mise a jour cellule sans VBA

creunch22

XLDnaute Nouveau
Bonjour à tous et bonne année!

J'utilise aujourd'hui la suite office 365.

J'ouvre quasiment tous mes fichiers via l'application web, cela m'empêche d'utiliser vba.

Voici ma problématique:

Dans un fichier, j'ai des données dans la colonne "B"

J'effectue des modifications dans les cellules de cette colonne ("pas traité" / "Traité" / "en cours").

J'aimerais pouvoir inscrire dans la colonne "C" la date de modification de la cellule "B", sans passer par VBA

Est ce possible?

Si je ne suis pas claire, n'hésitez pas à me le dire.

Merci d'avance pour vos réponses.

Bonne journée
 

creunch22

XLDnaute Nouveau
Merci Jha pour ta réponse.
J'avais vu cette solution qui est en effet la plus simple.
Cependant, elle ne correspond pas complément à mon besoin.
En effet, cette donnée (date) alimente d'autre formule derrière et surtout d'autres fichiers connectés.
L'actualisation de la date doit se faire par une formule.

Si tu as une idée, je suis preneur ;)

Bonne soirée
 

TooFatBoy

XLDnaute Barbatruc
Bonjour,

J'avais vu cette solution qui est en effet la plus simple.
Cependant, elle ne correspond pas complément à mon besoin.
En effet, cette donnée (date) alimente d'autre formule derrière et surtout d'autres fichiers connectés.
L'actualisation de la date doit se faire par une formule.
Pardon pour cette question, mais ça change quoi que la date soit saisie manuellement, entrée par <Ctrl>+<;>, ou calculée par formule ? 🤔
 
Dernière édition:

creunch22

XLDnaute Nouveau
Bonjour,


Pardon pour cette question, mais ça change quoi que la date soit saisie manuellement, entrée par <Ctrl>+<;>, ou calculée par formule ? 🤔
Le fichier sera remplie par plusieurs utilisateurs qui ne sont pas tous des "pro" de l'informatique.
si l'opération est manuelle, cela m'oblige à retourner sur le fichier régulièrement.

J'ai réussis via la fonction aujourd'hui() à récupéré la date de modification... mais elle s'actualise!
il faudrait bloquer son actualisation.
Savez vous faire cela?
 

Phil69970

XLDnaute Barbatruc
Bonjour à tous

@creunch22

j'ai ceci dans mes archives qui vient d'ici ==> https://forum.excel-pratique.com/excel/fonction-date-4929

Menu Outils / Options / Calcul / cocher "Itérations".

Saisir en A1 (par exemple) : =SI(A1=0;MAINTENANT();A1)

La date et l'heure en A1 restent figées.

Si cela ne te vas pas VBA obligatoire avec une fonction personnalisée :rolleyes:

Merci de ton retour

Bonnes année 2024 🍾
 

creunch22

XLDnaute Nouveau
Bonjour à tous

@creunch22

j'ai ceci dans mes archives qui vient d'ici ==> https://forum.excel-pratique.com/excel/fonction-date-4929

Menu Outils / Options / Calcul / cocher "Itérations".

Saisir en A1 (par exemple) : =SI(A1=0;MAINTENANT();A1)

La date et l'heure en A1 restent figées.

Si cela ne te vas pas VBA obligatoire avec une fonction personnalisée :rolleyes:

Merci de ton retour

Bonnes année 2024 🍾
Bonsoir phil!

et cousinhub ( j'avais pas vu ta réponse ;) )

Cette solution fonctionne hyper bien, mais seulement en local.
On perd la notion d'itération en ligne.
Cela entraine une "non actualisation"

Je pense que je vais devoir travailler en VBA pour solder cette problématique.
Dommage.

Merci pour votre aide!
 

Cousinhub

XLDnaute Barbatruc
Bonsoir phil!

et cousinhub ( j'avais pas vu ta réponse ;) )

Cette solution fonctionne hyper bien, mais seulement en local.
On perd la notion d'itération en ligne.
Cela entraine une "non actualisation"

Je pense que je vais devoir travailler en VBA pour solder cette problématique.
Dommage.

Merci pour votre aide!
Hello,
Ce n'est pas moi qui te réponds que l'autre forum, c'est un "Modérateur"
Juste, pour info, il est très mal vu de multiplier les "posts" sur plusieurs forums, donc, évite, à l'avenir....
Bonne soirée
 

Modeste geedee

XLDnaute Barbatruc
si il ne faut pas de VBA
ben il n'y a plus qu'une solution ctrl+ ou la taper à la main
Bonsour
Il reste également la possibilité de changer une formule en valeur figée :
Sélectionner la cellule contenant la formule, mettre le curseur dans la barre de formule puis appuyer sur F9 :
la formule disparait et est alors remplacée par valeur calculée a cet instant.
 

Discussions similaires

Statistiques des forums

Discussions
313 198
Messages
2 096 144
Membres
106 503
dernier inscrit
ngomez