Autres Rechcerchev sur deux feuilles différentes

talbimassinissa

XLDnaute Nouveau
Bonjour a tous,
Je me permets de vous contacter car je vais avoir besoin de mettre en place une recherche V sur deux feuilles différentes c'est à dire une fonction qui permets de récupérer des données dans la feuille kibana vers la feuille feuille1 (ci-joint mon fichier rien de confidentiel) le fichier étant volumineux j'en ai pris une partie pour le test j'ai déjà essayé mais cela n'a malheureusement pas fonctionné, quelqu'un aurait-il une solution a me proposer svp ? merci à vous, et vous souhaite une belle journée

Bien à vous,
 

Pièces jointes

  • test2.xls
    81 KB · Affichages: 3

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour talbimassinissa,
Les exemples de votre PJ ont des N° de facture qui n'existent pas dans Kibana, donc ça renvoie rien.
En PJ j'ai rajouté quelques N° existant pour tester, avec :
VB:
=SIERREUR(RECHERCHEV($A2;kibana!$A:$N;COLONNE();FAUX);"")
Colonne() incrémente la colonne où chercher, cela permet d'avoir la même formule partout.
J'ai mis ça sous forme de tableau structuré. Si vous rajouté un N° en colonne A, toutes les formules se mettent à jour automatiquement.
 

Pièces jointes

  • test2.xls
    97.5 KB · Affichages: 3

Discussions similaires

Statistiques des forums

Discussions
313 211
Messages
2 096 248
Membres
106 543
dernier inscrit
piegmp