Autres recette de cuisine et table des matières soucis ligne 35

stephane duff

XLDnaute Nouveau
Bonjour,
je m'arrache les cheveux depuis plus d'une semaine ce pourquoi cette demande d'aide.
j'ai créé une table des matières et des fiches recettes en liaison avec elle.
néanmoins cela bloque à partir de la ligne 35
Avant tout passe et ensuite plus à partir de cette ligne ?

si je change l'ordre alphabétique des produits, cela fonctionne mais certaines lignes ne fonctionnent plus comme la 10 ou la 12 ...
Merci d'avance la communauté pour votre savoir
 

Pièces jointes

  • table + recettes.xlsx
    51.5 KB · Affichages: 28
Solution
Bonjour,
je m'arrache les cheveux depuis plus d'une semaine ce pourquoi cette demande d'aide.
j'ai créé une table des matières et des fiches recettes en liaison avec elle.
néanmoins cela bloque à partir de la ligne 35
Avant tout passe et ensuite plus à partir de cette ligne ?

si je change l'ordre alphabétique des produits, cela fonctionne mais certaines lignes ne fonctionnent plus comme la 10 ou la 12 ...
Merci d'avance la communauté pour votre savoir
Bonjour,
La plage de"Excel_BuiltIn_Data_Form" s'arrête a la ligne 35 il est donc normal de ne pas trouvé le n°35 qui se trouve en ligne 36
1656179641652.png

Il serait sage de nommer cette plage dynamiquement
Code:
=DECALER(MATIERES!$A$1:$F$1;;;NBVAL(MATIERES!$B:$B))
...

Jacky67

XLDnaute Barbatruc
Bonjour,
je m'arrache les cheveux depuis plus d'une semaine ce pourquoi cette demande d'aide.
j'ai créé une table des matières et des fiches recettes en liaison avec elle.
néanmoins cela bloque à partir de la ligne 35
Avant tout passe et ensuite plus à partir de cette ligne ?

si je change l'ordre alphabétique des produits, cela fonctionne mais certaines lignes ne fonctionnent plus comme la 10 ou la 12 ...
Merci d'avance la communauté pour votre savoir
Bonjour,
La plage de"Excel_BuiltIn_Data_Form" s'arrête a la ligne 35 il est donc normal de ne pas trouvé le n°35 qui se trouve en ligne 36
1656179641652.png

Il serait sage de nommer cette plage dynamiquement
Code:
=DECALER(MATIERES!$A$1:$F$1;;;NBVAL(MATIERES!$B:$B))
Référence de la plage et formules modifiées en pj
 

Pièces jointes

  • table + recettes.xlsx
    72.3 KB · Affichages: 21
Dernière édition:

soan

XLDnaute Barbatruc
Inactif
Bonsoir stéphane, Jacky,

bienvenue sur le site XLD ! :)

1) formules de la ligne 14 :

* en B14 : =SI($A14="";"";DECALER(MATIERES!$B$1;$A14;0))

* en C14 : =SI($A14="";"";DECALER(MATIERES!$C$1;$A14;0))

* en D14 : =SI($A14="";"";DECALER(MATIERES!$D$1;$A14;0))

* en E14 : =SI($A14="";0;DECALER(MATIERES!$F$1;$A14;0))

* en G14 : =E14*F14

* en i14 : =SI($A14="";"";DECALER(MATIERES!$E$1;$A14;0))

(toutes ces formules sont déjà étirées jusqu'en ligne 31)

2) autres formules :

* en G32 : =SOMME(G14:G31)

* en G33 : =SI(C6=0;0;G32/C6)

* en G34 : =SI(G36=0;0;G35/G36)

* en G35 : =G36-G33

soan
 

Pièces jointes

  • table + recettes.xlsx
    46.6 KB · Affichages: 17

Jacky67

XLDnaute Barbatruc
Bonsoir stéphane, Jacky,

bienvenue sur le site XLD ! :)

1) formules de la ligne 14 :

* en B14 : =SI($A14="";"";DECALER(MATIERES!$B$1;$A14;0))

* en C14 : =SI($A14="";"";DECALER(MATIERES!$C$1;$A14;0))

* en D14 : =SI($A14="";"";DECALER(MATIERES!$D$1;$A14;0))

* en E14 : =SI($A14="";0;DECALER(MATIERES!$F$1;$A14;0))

* en G14 : =E14*F14

* en i14 : =SI($A14="";"";DECALER(MATIERES!$E$1;$A14;0))

(toutes ces formules sont déjà étirées jusqu'en ligne 31)

2) autres formules :

* en G32 : =SOMME(G14:G31)

* en G33 : =SI(C6=0;0;G32/C6)

* en G34 : =SI(G36=0;0;G35/G36)

* en G35 : =G36-G33

soan
Hello soan :)
Attention tout de même si un utilisateur décide de changer le tri de la base 😰
 

stephane duff

XLDnaute Nouveau
merci à tous les deux.
modifier le chiffre 34 par 300 pour être tranquille c'est possible également donc si je vous suit, ou mieux vaut utiliser ta formule jacky
nommer c cette plage dynamiquement c'est donc utiliser ta formule modifié, ok mais quels sont les avantages ?
merci d'avance pour le temps passé
 

Jacky67

XLDnaute Barbatruc
nommer c cette plage dynamiquement c'est donc utiliser ta formule modifié, ok mais quels sont les avantages ?
merci d'avance pour le temps passé
Re..
L' avantage, c'est que si une ligne est ajoutée dans la feuille "MATIERES" celle-ci est pris en compte automatique sans avoir à modifier la plage ou la formule qui utilise cette plage nommée dynamiquement(Excel_BuiltIn_Data_Form).
Exemple:
=SI($A14="";"";RECHERCHEV($A14;Excel_BuiltIn_Data_Form;COLONNE();FAUX))
Et surtout
Pour ne pas avoir à demander pourquoi cela ne fonctionne pas
"cela bloque à partir de la ligne 35"

Qui me semble avoir été à l'origine du disfonctionnement
 
Dernière édition:

stephane duff

XLDnaute Nouveau
Encore merci pour tout
j'aurais besoin si ce n'est pas abuser de créer une feuille sommaire ou je pourrais y mettre les différentes recettes pour ne pas a devoir sans cesse faire défiler les feuilles une à une dans le bas de page comme je penses y ajouter de nombreuses recettes. le mieux serait de re créer un sujet ?
merci
 

TooFatBoy

XLDnaute Barbatruc
Bonjour,

Une proposition en pièce jointe, avec utilisation d'un tableau structuré.
Donc, normalement, pas non plus besoin de modifier les formules de la feuille "TEST". ;)
 

Pièces jointes

  • table_+_recettes_(TooFatBoy-v1).xlsx
    43 KB · Affichages: 17
Dernière édition:

TooFatBoy

XLDnaute Barbatruc
j'aurais besoin si ce n'est pas abuser de créer une feuille sommaire ou je pourrais y mettre les différentes recettes pour ne pas a devoir sans cesse faire défiler les feuilles une à une dans le bas de page comme je penses y ajouter de nombreuses recettes.
Tu veux dire que tu veux mettre une recette par feuille, et avoir une feuille dans laquelle il y aurait un tableau listant tous les noms des recettes (noms des onglets ???) ?
Tu accepterais un peu de code VBA ?


le mieux serait de re créer un sujet ?
Généralement on crée un sujet par question. Mais vu que c'est le même projet, je pense que tu peux faire comme tu veux. ;)
 

stephane duff

XLDnaute Nouveau
Bonjour et merci pour ton travail TooFatboy
Et oui tu as bien compris pour le sommaire c'est exactement cela.
Plusieurs feuilles renommées en nom de recette. Et une feuille sommaire pour y classer toutes ses recettes.
Je ne connais pas le VBA mais si cela permet d'avoir un super rendu je veux bien oui merci
 

TooFatBoy

XLDnaute Barbatruc
Une proposition en pièce jointe avec un bout de code VBA.

A l'ouverture du fichier, tu seras sur la feuille "Liste recettes" et le tableau sera vide.
Si tu vas sur une autre feuille, à chaque fois que tu reviendras sur la feuille "Liste recettes", le tableau sera automatiquement actualisé avec la liste des noms des onglets du classeur.


[edit]
Je crois que tu as raison : l'ouverture d'un autre sujet serait peut-être mieux. ;)
[/edit]
 

Pièces jointes

  • table_+_recettes_(TooFatBoy-v1).xlsm
    55.8 KB · Affichages: 18
Dernière édition:

stephane duff

XLDnaute Nouveau
Une proposition en pièce jointe avec un bout de code VBA.

A l'ouverture du fichier, tu seras sur la feuille "Liste recettes" et le tableau sera vide.
Si tu vas sur une autre feuille, à chaque fois que tu reviendras sur la feuille "Liste recettes", le tableau sera automatiquement actualisé avec la liste des noms des onglets du classeur.


[edit]
Je crois que tu as raison : l'ouverture d'un autre sujet serait peut-être mieux. ;)
[/edit]
le rendu est très sympa mais du sommaire je ne peux aller sur les feuilles créées ?
 

Discussions similaires

Statistiques des forums

Discussions
312 875
Messages
2 093 143
Membres
105 638
dernier inscrit
cordier