XL 2019 Problème de MFC

Quicksland

XLDnaute Occasionnel
Bonjour le Forum ;)

Dans le fichier ci-joint , dans la feuille "Janvier" j'ai une MFC qui colore les samedis et dimanches "A4:D34"

mais lorsque j'étend la sélection "A4:J34" cela ne fonctionne pas du tout comme je le souhaiterai ( voir l'exemple du problème dans la feuille "Fevrier"

Je souhaiterai également que les cellules des jours fériés apparaissent ( la liste jours Fériés se trouve dans l'onglet "LISTE"

J'espère avoir été clair

Merci d'avance pour l'aide :)
 

Pièces jointes

  • BOSQUET 2023.xlsm
    139.9 KB · Affichages: 7
Solution
RE...
Dans mon exemple, il y a 2 plages nommées
An et JFR
An que je viens de modifier, car je n'avais pas vu que l'année change en feuille Janvier
Donc
An fera référence à "=JANVIER!$F$1"
JFR fera référence à la plage"=LISTE!$E$2:$E$14"
JFR sera mis automatiquement à jour à la modification en Feuille Janvier F1(Nommée An)
La formule de la MFC des jours fériés sera donc
=NB.SI(JFR;$D4) dans toutes les feuilles
Si $D4 est présent dans la plage JFR alors peinturlurer la ligne entre colonnes A et J
En PJ avec toutes les mfc 😅
Re,

Ok merci pour les précisions ;)

Super bon boulot 👍

Merci pour tout ...

Bon weekend a toi ainsi qu'a @TooFatBoy ;)

Jacky67

XLDnaute Barbatruc
Bonjour le Forum ;)

Dans le fichier ci-joint , dans la feuille "Janvier" j'ai une MFC qui colore les samedis et dimanches "A4:D34"

mais lorsque j'étend la sélection "A4:J34" cela ne fonctionne pas du tout comme je le souhaiterai ( voir l'exemple du problème dans la feuille "Fevrier"

Je souhaiterai également que les cellules des jours fériés apparaissent ( la liste jours Fériés se trouve dans l'onglet "LISTE"

J'espère avoir été clair

Merci d'avance pour l'aide :)
Bonjour,
Voir en PJ
J'ai pris les dates de la colonne D
J'ai modifié les jours fériés pour les rendre automatique
J'ai fait les MFC de Janvier à Mai (2 couleurs, une pour les fins de semaine et une pour les fériés)
A toi de faire les autres mois
 

Pièces jointes

  • BOSQUET 2023.xlsm
    144.3 KB · Affichages: 10
Dernière édition:

Quicksland

XLDnaute Occasionnel
Bonjour,
Voir en PJ
J'ai pris les dates de la colonne D
J'ai modifié les jours fériés pour les rendre automatique
J'ai fait les MFC de Janvier à Mai (2 couleurs, une pour les fins de semaine et une pour les fériés)
A toi de faire les autres mois
Bonsoir @Jacky67

Le top 👍

Bien vu pour la colonne "D"

Ok pour les autres mois ;)

Merci pour ton aide et merci pour la participation de @riton00

Bonne soirée ...
 

Jacky67

XLDnaute Barbatruc
Bonjour @Jacky67

J'ai bien compris pour la MFC "=JOURSEM($D4;2)>5" s'applique à "=$A$4:$J$34"

Mais je pèche avec celle des jours fériés :rolleyes:

Serait-il possible d'avoir une explication ?

Merci et bonne journée ;)
RE...
Dans mon exemple, il y a 2 plages nommées
An et JFR
An que je viens de modifier, car je n'avais pas vu que l'année change en feuille Janvier
Donc
An fera référence à "=JANVIER!$F$1"
JFR fera référence à la plage"=LISTE!$E$2:$E$14"
JFR sera mis automatiquement à jour à la modification en Feuille Janvier F1(Nommée An)
La formule de la MFC des jours fériés sera donc
=NB.SI(JFR;$D4) dans toutes les feuilles
Si $D4 est présent dans la plage JFR alors peinturlurer la ligne entre colonnes A et J
En PJ avec toutes les mfc 😅
 

Pièces jointes

  • 1691232192100.png
    1691232192100.png
    29.4 KB · Affichages: 11
  • BOSQUET 2023.xlsm
    145.6 KB · Affichages: 4
Dernière édition:

Quicksland

XLDnaute Occasionnel
RE...
Dans mon exemple, il y a 2 plages nommées
An et JFR
An que je viens de modifier, car je n'avais pas vu que l'année change en feuille Janvier
Donc
An fera référence à "=JANVIER!$F$1"
JFR fera référence à la plage"=LISTE!$E$2:$E$14"
JFR sera mis automatiquement à jour à la modification en Feuille Janvier F1(Nommée An)
La formule de la MFC des jours fériés sera donc
=NB.SI(JFR;$D4) dans toutes les feuilles
Si $D4 est présent dans la plage JFR alors peinturlurer la ligne entre colonnes A et J
En PJ avec toutes les mfc 😅
Re,

Ok merci pour les précisions ;)

Super bon boulot 👍

Merci pour tout ...

Bon weekend a toi ainsi qu'a @TooFatBoy ;)
 

Discussions similaires

Réponses
8
Affichages
271
Réponses
2
Affichages
233
Réponses
1
Affichages
198
Compte Supprimé 979
C

Statistiques des forums

Discussions
313 204
Messages
2 096 208
Membres
106 529
dernier inscrit
ironmachine