Microsoft 365 Formule : Atteindre un seuil et repartir à 0

klin89

XLDnaute Accro
Bonjour le forum, :)

J'en appelle une nouvelle fois aux experts en formules.
En colonne B, je saisis des heures travaillées sous forme décimale.
En colonne C, j'aimerais cumuler ces heures jusqu'à atteindre le seuil de 35 puis repartir à 0.
Ainsi en C6, j'ai atteint le seuil de 35 puisque j'arrive à un cumul égal à 35.37
En C7, je repars à 0 et reprend le solde qui est alors de 0.37 ------> 35.37 - 35

Pour corser le tout, j'aimerais ajouter un coefficient aux heures travaillées les samedi, dimanches et jours fériés.
Samedis ----> 1,25
Dimanches et jours fériés ----> 1,5
Ainsi le lundi 01 avril, 4,33 se convertit en 6,5 après application du coefficient de 1.5, soit 4h20 égale 6h30
En C9, le cumul se retrouve donc à 6,87 -----> 0,37 + 6,5

Atteindre_Seuil_35.png

Dans le fichier, pour plus de clarté, j'ai converti les heures décimales sous la forme heure/minute dans des colonnes adjacentes, j'ai mis aussi la liste des jours fériés pour vous aider.

Pouvez-vous m'aider à résoudre ce problème par formules, je vous joins le fichier.
Merci d'avance klin89
 

Pièces jointes

  • atteindre_seuil_35.xlsm
    11.5 KB · Affichages: 6

job75

XLDnaute Barbatruc
Bonjour klin89, TooFatBoy,

Insérer une ligne 1 supplémentaire pour pouvoir mettre cette formule en D3 :
Code:
=SI(N(D2)<35;MIN(35;N(D2)+B3*C3);N(D1)+N(B2)*N(C2)+B3*C3-35)
En colonne C le coefficient à appliquer.

A+
 

Pièces jointes

  • atteindre_seuil_35.xlsm
    13.3 KB · Affichages: 9

klin89

XLDnaute Accro
Re à tous, :)

Bien joué la colonne supplémentaire, je n'y avais même pas pensé.
Ça m'a l'air d'être tout bon, Job75
Merci aussi à toi TooFatBoy.
Je vais quand même retester avec des valeurs un peu incongrues même si cela n'a vraiment aucun sens.
Je veux dire par là que je pourrais additionner des valeurs quelconques pour atteindre un seuil de 1000 par exemple.
klin89
 
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
313 192
Messages
2 096 069
Membres
106 486
dernier inscrit
Barklem