XL 2021 Problème avec la fonction Mois.Décalé dans Index.Equiv

Arthur M

XLDnaute Nouveau
Bonjour à tous,

j'ai un problème que je n'arrive pas à résoudre. Je souhaite simuler un décalage d'encaissement de chiffre d'affaires sur la base de la fonction "mois.decalé". La fonction Index.Equiv que j'utilise fonctionne pour certains mois mais pas pour d'autres (mai-septembre-octobre'25 et fevrier-mars-26) où la formule affiche une erreur.

Pourriez-vous m'aider à comprendre ce qui ne va pas dans ma formule? Je vous joins un exemple en pièce jointe.

Merci beaucoup d'avance!!!

Arthur
 

Pièces jointes

  • Exemple - Décalage encaissement.xlsx
    137.8 KB · Affichages: 4

JHA

XLDnaute Barbatruc
Bonjour à tous,

C'est normal, les dates ne correspondent pas.
J'ai tout mis en fin de mois.
A essayer

VB:
=SIERREUR(INDEX($C$6:$P$6;;EQUIV(FIN.MOIS(MOIS.DECALER(E$5;-$C$2);0);$C$5:$P$5;0));"n.a.")

JHA
 

Pièces jointes

  • Exemple - Décalage encaissement.xlsx
    135.7 KB · Affichages: 3

Discussions similaires

Réponses
2
Affichages
353

Statistiques des forums

Discussions
313 195
Messages
2 096 101
Membres
106 495
dernier inscrit
dylan.44