Plusieurs si pour vérifier le contenu des cellules

enemme

XLDnaute Nouveau
Bonjour à tous.


Je suis nouveau sur le forum et jusqu’à présent, j’ai toujours réussi à m’en sortir tout seul ou grâce à vos différents messages. Dieu vous garde. Aujourd’hui, je viens vers vous pour vous poser une question qui me taquine depuis quelques jours sans que je puisse trouver la solution.
Explications :
J’ai deux cellules en A1 et A2.
A1 contient déjà une formule avec un sierreur = n’affiche rien "".
A2 doit contenir une valeur mise à la main si jamais A1 ne contient rien.

Le problème vient de A3 et voici ce que je souhaite :
SI A1 est rempli alors fais une opération. Si A1 est vide alors regarde si A2 est rempli. SI A2 est rempli alors opération. SI A1 et A2 sont vides alors ne fais rien.

J'ai tenté des si imbriqués mais je n'arrive pas et je commence à perdre la logique.

Edit : estvide me renvoyant FAUX (sans doute en raison du sierreur alors "")
 

Calvus

XLDnaute Barbatruc
Re : Plusieurs si pour vérifier le contenu des cellules

Bonjour et bienvenue,

si j'ai bien compris ta demande, voici la formule.
Tu remplaceras l'opération (ici j'ai simplement multiplié par 2) à faire puisque tu ne dis pas de quelle opération il s'agit.
Code:
=SI(A1<>"";A1*2;SI(A2<>"";A2*2;""))

Cordialement
 

enemme

XLDnaute Nouveau
Re : Plusieurs si pour vérifier le contenu des cellules

Je vous remercie tout d'abord de votre rapidité.
@JBARBE cela fonctionne parfaitement.
Vous venez de me permettre de réaliser un superbe document d'audit qui évite les #valeur.

Mille merci
 

Discussions similaires