XL 2019 PB MEF conditionnel sur plusieurs période

nadem0068

XLDnaute Junior
Bonjour à tous,

une fois de plus je viens vers vous afin de solliciter votre aide.;)
je souhaite simplifier une formule que j'utilise pour une MEFC qui me permet de faire apparaître une période.
Le PB c'est que ma formule devra être ajusté à chaque fois que je voudrais ajouter une période supplémentaire ce qui peut donner une formule extrêmement grande s'il y a beaucoup de période à ajouter.
Pour des dates uniques je me sert de la formule "ET" combiné avec la formule "RECHERCHE V" ce qui me permet de pouvoir ajouter autant de date que je veut sans à avoir à modifier la formule.
Je souhaiterais obtenir le même genre de formule pour des période.

Merci d'avance à tous ceux qui prendrons le temps de ce penchais sur mon PB.;)
Belle journée à tous.
 

Pièces jointes

  • formule MEF période.xlsx
    12.9 KB · Affichages: 2

RyuAutodidacte

XLDnaute Impliqué
Supporter XLD
Bonjour,

J'ai modifié le fichier, il suffit de rajouter les les dates voulues dans les tableaux
Pour les date de début et fin :
VB:
=NB.SI.ENS(INDIRECT("Tableau2[Début]");"<="&A1; INDIRECT("Tableau2[Fin]");">="&A1)
Pour les dates d'anniversaires :
VB:
=NB.SI(INDIRECT("Tableau1[Anniversaires]");A1)=1

Après selon ce que vous voulez prioriser, il faudra passer l'une des règles de MFC au dessus de l'autre
 

Pièces jointes

  • formule MEF période.xlsx
    13 KB · Affichages: 1
Dernière édition:

job75

XLDnaute Barbatruc
Bonsoir nadem0068, Ryu,

Autre solution avec cette formule pour la MFC :
Code:
=SOMMEPROD((A1>=Début)*(A1<=Fin))
Début et Fin étant des noms définis à partir de Tableau2.

A+
 

Pièces jointes

  • formule MEF période.xlsx
    12.9 KB · Affichages: 4

Discussions similaires

Membres actuellement en ligne

Statistiques des forums

Discussions
312 922
Messages
2 093 644
Membres
105 775
dernier inscrit
assen