numéroter un champ

  • Initiateur de la discussion candide
  • Date de début
C

candide

Guest
Bonjour,
je cherche à automatiser la numérotation de lignes comme le fichier joint.
Comme on peut le voir c'est un classement pour un même compte client sur un ratio décroissant.
Le nombre de référence par client est variable.
J'ai donc remplie manuellement la colonne rang mais étant donné le nombre d'enregistrements de ma feuille je ne pourrait pas le faire sans automatisation
Merci d'avance [file name=Classeur2_20060503144416.zip size=3117]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/Classeur2_20060503144416.zip[/file]
 

Pièces jointes

  • Classeur2_20060503144416.zip
    3 KB · Affichages: 19

andré

XLDnaute Barbatruc
Salut candide et pierrejean,
salut le forum,

Une petite formule.
En D2 : =SI(A2=A1;D1+1;1)
Double-clic sur la petite croix (en forme de '+') dans le coin inférieur droit de D2 et la formuile est recopiée sur la colonne D tant qu'il y a des valeurs en colonne C.

Â+
 
C

candide

Guest
Merci Pierre jean,
C'est tout à fait ce que je souhaitais.
Comment puis je programmer cette touche sur un autre classeur est ce une macro est ce du vba?
Je suis loin de savoir en faire autant.
Es tu aussi fort sur access?
Cordialement
 

pierrejean

XLDnaute Barbatruc
re

salut andré

@ candide

oui il s'agit d'une macro ecrite en vba

pour voir la macro:
Affichage >barre d'outils > boite à outils controles
click sur l'equerre
visualiser le code

pour la mettre dans un autre classeur:
creer le bouton par
Affichage >barre d'outils > boite à outils controles >bouton de commande
click sur l'equerre
ensuite cliquer visualiser le code et recopier la macro
 

Discussions similaires

Statistiques des forums

Discussions
313 230
Messages
2 096 410
Membres
106 604
dernier inscrit
JulienMan