Autres Nombre de jours ouvrés heures et minutes entre 2 dates

RUBI17

XLDnaute Nouveau
Bonjour à tous,
J'ai un fichier avec 3 colonnes "date du ticket", " date d'intervention" et "délai"
Je n'arrive pas à afficher le nombre de jours lorsqu'il est supérieur ou égale à 24h notamment sur les lignes 5 et 6
Pouvez-vous m'aider ?
Avec mes remerciements
 

Pièces jointes

  • Délai en jours heures minutes.xlsx
    9.7 KB · Affichages: 5

RUBI17

XLDnaute Nouveau
Merci JHA pour ton retour rapide, ta formule est très bien et bien plus simple que la mienne.
Sachant qu'une journée c'est 8 heures, dans la cellule H6 le résultat affiche 24:38:00, est il possible d'afficher 3 jours 0 heure 38 minutes ?
Merci encore pour ton aide
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

A essayer
VB:
=SI(NB.JOURS.OUVRES.INTL($A2;$B2;1;fériés)-1=0;MOD($B2-$A2;1);NB.JOURS.OUVRES.INTL($A2;$B2;1;fériés)+SI(MOD($B2-$A2;1)>"08:00"*1;MOD($B2-$A2;1)-"08:00";MOD($B2-$A2;1)))

JHA
 

Pièces jointes

  • Délai en jours heures minutes bis.xlsx
    15.1 KB · Affichages: 1

RUBI17

XLDnaute Nouveau
JHA j'ai essayé ta formule avec une petite modification, j'ai remplacé le signe >"08:00" par ="08:00"
cela permet de corriger les heures lorsque l'heure d'intervention dépasse 16:00.
Par contre je suis sans solution pour les 3 premières lignes surtout quand l'intervention est le même jour que le ticket.
Je te remercie pour le temps passé :)
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Peut-être en ajoutant une condition.
VB:
=SI(B2-A2=1;"08:00"*1;SI(NB.JOURS.OUVRES.INTL($A2;$B2;1;fériés)-1=0;MOD($B2-$A2;1);NB.JOURS.OUVRES.INTL($A2;$B2;1;fériés)+SI(MOD($B2-$A2;1)="08:00"*1;MOD($B2-$A2;1)-"08:00";MOD($B2-$A2;1))))

JHA
 

Pièces jointes

  • Délai en jours heures minutes bis (1).xlsx
    15.8 KB · Affichages: 1

RUBI17

XLDnaute Nouveau
j'ai repris le fichier avec de nouvelles modifications, tous les cas de figures fonctionnent sauf
sur les lignes 10 et 11 lorsque l'heure d'intervention est inférieur à celle du ticket
 

Pièces jointes

  • Délai en jours heures minutes bis (1).xlsx
    9.8 KB · Affichages: 1

Discussions similaires