XL 2010 NB.SI.ENS 2 CRITERES SUR UNE GRANDE PLAGE

ymanot

XLDnaute Occasionnel
Bonjour,
je souhaite faire une recherche à partir de 2 critères sur 1 plage étendue.
j'ai bien utilisé nb.si.ens comme suit :NB.SI.ENS($C$5:$AZ$40;C43;$C$5:$AZ$40;B44) mais j'ai l'impression que cette formule ne fonctionne que sur une recherche verticale.

Sachant que j'ai un tableau en B43 sur lequel je souhaite procéder au récapilatif selon les valeurs en colonne B à croiser avec les valeurs de la ligne 43.
Les tableaux de recherche étant situés de B à AZ. Le tout sans Macro si possible.

merci pour votre aide
thierry
 

Pièces jointes

  • nb.si.ens excel doxnload repart apsa.xlsx
    18.1 KB · Affichages: 10

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonsoir Ymanot, Djidji,
@Djidji,
Pas compris la même chose. :rolleyes:
J'ai compris qu'il fallait analyser les colonnes paires ( B,D,F,H ... ) pour y trouver la classe et voir dans les colonnes impaires (C,E,G...) si on trouve simultanément la matière (ligne 43).
Si c'est bien ce qui est désiré, on peut le faire avec :
VB:
=NB.SI.ENS($B$4:$AY$40;$B44;$C$4:$AZ$40;C$43)
Voir PJ.
 

Pièces jointes

  • nb.si.ens excel doxnload repart apsa (2).xlsx
    22.6 KB · Affichages: 5

Discussions similaires

Statistiques des forums

Discussions
312 934
Messages
2 093 736
Membres
105 803
dernier inscrit
metroMBP