Moyenne de moyenne avec cellules non-contiguës et vides !

guy244

XLDnaute Nouveau
Bonjour à tous,
depuis plusieurs jours je parcours le forum pour trouver une solution à mon problème : faire une moyenne de moyenne de cellules non contigûës et dont certaines sont vides.
Dans mon tableau j'aimerais par exemple en Récap!M3 le pourcentage moyen pour la polyvalence caisse sur les 3 polyvalences possibles sur toute l'année et pas seulement sur 4 mois ; si je continue la formule actuelle elle me renvera #div/0.
Merci d'avance.
 

Pièces jointes

  • EQUITE CHARTE.xls
    32 KB · Affichages: 190

soenda

XLDnaute Accro
Re : Moyenne de moyenne avec cellules non-contiguës et vides !

Bonjour le fil, guy244

depuis plusieurs jours je parcours le forum pour trouver une solution à mon problème
(...)
Quelques exemples en BC7 :

La formule standard, version 2007 (choisir : 0 ou "")
Code:
=SIERREUR(BC4*100/SOMME($BC$4:$BH4);0)
La même formule, version 2003
Code:
==SI(ESTERR(BC4*100/SOMME($BC$4:$BH4));0;BC4*100/SOMME($BC$4:$BH4))
Si tu n'as pas de nombre négatif, tu peux aussi écrire
Code:
=BC4*100/MAX(SOMME($BC$4:$BH4);1)
...

A plus
 

Discussions similaires

Statistiques des forums

Discussions
312 922
Messages
2 093 644
Membres
105 774
dernier inscrit
Tibenjah