Microsoft 365 Mettre en couleur un texte en fonction d’une fonction si

Pierre111

XLDnaute Nouveau
Bonjour
J’aimerais savoir comment on peut modifier la couleur de mon texte en fonction du résultat de la fonction si
Si j’obtiens la valeur si vrai à mon test logique alors là texte se mette en vert et si j’obtiens la valeur si faux a mon test logique le texte se mette en rouge
Petite précision la valeur si vrai et la valeur si faux sont dépendantes d’une autre feuille car elles vont chercher une information dans cette feuille la
Merci d’avance pour votre aide
 

Hasco

XLDnaute Barbatruc
Repose en paix
Bonjour,

Peut-être que publier une deuxième discussion à 4 minutes de la première, est-ce exagéré ! Non ?
Si vous vouliez simplement modifiez votre texte, vous pouviez le faire cliquant sur le bouton 'Modifier' présent en bas des posts que vous avez écrits.

Pour votre question, une mise en forme conditionnelle devrait suffire.
Onglet "Accueil' bouton "Mise en forme conditionnelle" du groupe "Style"

Cordialement
 

Pierre111

XLDnaute Nouveau
Je pensais que mon premier message n'étais pas parti dsl.
Je n'y arrive pas avec une mise en forme conditionnelle.
J'ai joins des fichiers pour que mon problème soit plus explicite
 

Pièces jointes

  • Classeur1.xlsx
    175.7 KB · Affichages: 6
  • Classeur2.xlsx
    16.7 KB · Affichages: 3
  • Classeur3.xlsx
    17.4 KB · Affichages: 3

Hasco

XLDnaute Barbatruc
Repose en paix
Re,

Lorsque vous posez une question, il faut TOUT dire.
Par exemple : que votre recherche (test de fonction si) porte sur plusieurs classeurs !
Les choses ne se traitent pas toujours de la même façon.

Cordialement
 

Hasco

XLDnaute Barbatruc
Repose en paix
Re,

Vous pouvez insérer une colonne avec la formule suivante :
=SIERREUR(ESTNUM(EQUIV(B2;'[Pierre111-2.xlsx]A'!$B:$B;0))*2;0) + SIERREUR(ESTNUM(EQUIV(B2;'[Pierre111-3.xlsx]A'!$B:$B;0))*4;0)
Qui renverra 2 si la référence est trouvée dans le fichier 2.
4 si la référence est dans le fichier 3
et 6 si elle est dans les deux.

A ce moment-là vous pourrez faire votre mise en forme conditionnelle.
D'ailleurs vous ne précisez pas la couleur pour les références présentes dans les 2 fichiers externes.

Mais, et ce n'est que mon avis, au vu de vos fichiers et leur formules, je me dis que vous vous dirigez tout droit vers le montage d'une usine à gaz qui pour une fonctionnalité au moindre bénéfice.

Pourquoi n'utilisez-vous pas Power query par exemple ? Pourquoi faire 3 fichiers ?

Cordialement
 

Statistiques des forums

Discussions
312 927
Messages
2 093 693
Membres
105 785
dernier inscrit
circes21