XL 2019 Mettre en couleur des cellules fusionnés selon une autre cellule

Yassin9

XLDnaute Junior
Bonjour,

Je vous contacte pour savoir si vous aviez par hasard le moyen de mettre en couleur verte les localisations qui apparaissent dans les 5 premiers résultats du tri année du TDC dans le fichier Excel, par exemple pour le point +2 en vert en colonne A8, mettre en couleur la localisation +2 ( avec le "+" qui dérange pour les conditions ) sur le tableau en colonne I,J ligne 9,10,11,12 ( avec l'image qui est là si possible ) comme l'indique la flèche, et la couleur change de localisation si le top 5 change avec le tri TDC bien évidemment.

Je joint le fichier Excel c'est plus parlant.

Merci de votre lecture !
 

Pièces jointes

  • dashboard-copie-.xlsm
    574.1 KB · Affichages: 8
Solution
je te remets le fichier ici
et en image:
1654694396066.png

Deadpool_CC

XLDnaute Accro
Bonjour

même idée que Chris : basé sur les MFC
mais avec la formule =SI(SIERREUR(EQUIV(E5;$A$8:$A$12;0);FAUX);VRAI;FAUX)
dans fichier joint avec la MFC pour ta première zone ... à reproduire ensuite pour les autres.
ps 1 : dans chaque cellule de ta zone, j'ai mis le texte en blanc du nom de la cellule de la zone (exemple "'>1")
ps 2 : je te conseille dans tes image de définir le blanc comme couleur de transparence :)
 

Pièces jointes

  • dashboard-copie-.xlsm
    542.5 KB · Affichages: 3
Dernière édition:

chris

XLDnaute Barbatruc
RE
la formule =SI(SIERREUR(EQUIV(E5;$A$8:$A$12;0);FAUX);VRAI;FAUX)
Le SI est implicite dans une MFC et le sinon inutile de même que le test d'erreur : dans tous les cas où ce n'est pas OK eh bien pas de MFC

Inutile de faire n MFC une seule suffit et la formule devient
VB:
=EQUIV(E$4&$D5;$A$8:$A$12;0)
1654693245591.png


On peut aussi simplifier ma formule ainsi
VB:
=NB.SI($A$8:$A$12;"="&E$4&$D5)
 
Dernière édition:

Deadpool_CC

XLDnaute Accro
Dans le fichier mis à jour : 1 seul MFC avec 3 plages d'application
Après oui la formule est simplifiable mais je n'étais plus certain du renvoi de Equiv() si pas trouvé et comment réagirais la MFC ... lol
=> plus qu'à attendre le retour de Yassin9 :cool:
 

chris

XLDnaute Barbatruc
Re
E$4&$D5 : ce qui est en ligne 4 commençant en E selon les cellules, accolé à ce qui est colonne D commençant en ligne 5 selon les cellules

Donne donc en cellule E5 <1, en G5 >1, en E13 <3, en I9 2+ etc

sélectionner E5:J16, taper la formule
VB:
=SIERREUR(INDEX($B$8:$B$12;EQUIV(E$4&$D5;$A$8:$A$12;0));"")
et valider par CTRL Entrée
 

Yassin9

XLDnaute Junior
Rebonjour à vous @chris, je bute sur ta formule lorsque la localisation dans le tableau et composé d'un "*" elle colore souvent toute la section.
Comme par exemple ici :
Normalement les cases du tableau en *1,*2 et *3 ne doivent pas être colorés. Seulement les <1, +1 et +2 par rapport aux 5 localisations en vert claire à gauche.

1654762760479.png

Auriez-vous une astuce par hasard ?
Merci de votre lecture
 

Pièces jointes

  • dashboard2.xlsm
    543.3 KB · Affichages: 1

Discussions similaires

Statistiques des forums

Discussions
312 801
Messages
2 092 245
Membres
105 314
dernier inscrit
SABER ABD