jours ouvrés week end et somme prod

baud95

XLDnaute Nouveau
Bonsoir,

Merci pour votre aide sur ce forum.

Malgré mes recherches je n'arrive pas à trouvé la bonne formule.

Je souhaiterais faire la somme des produits si le matricule correspond avec l'heure mais également différencier les jours ouvrés des jours fériés et des week ends.
la formule pour le total donne ça :

=SOMMEPROD((($'feuille de cacul'.$B$2:$B$1352=$A$2)*($'feuille de cacul'.D$2:D$1352=1)))

la zone où est positionné la date est en C2:C1352

Pouvez vous m'aider... désolé mais meme en zippant mon fichier, celui-ci est trop lourd.

Merci

Cordialement.
 

mth

XLDnaute Barbatruc
Re : jours ouvrés week end et somme prod

Bonsoir,

tu n'es pas obligé de déposer le fichier en entier, juste un extrait de quelques données représentant ton problème suffira largement.

Bien à toi,

mth

Edit: :) bonsoir Tibo et JHA :)
Bises,
m
 
Dernière édition:

Tibo

XLDnaute Barbatruc
Re : jours ouvrés week end et somme prod

Bonsoir,

Les noms de tes feuilles me paraissent un peu curieux.

Essaye avec :

Code:
=SOMMEPROD((($'feuille de cacul'.$B$2:$B$1352=$A$2)*($'feuille de cacul'.
D$2:D$1352=1)*(JOURSEM($'feuille de cacul'.C$2:C$1352);2)<6)))
Donnera les valeurs pour les jours ouvrés (du lundi au vendredi)

Pour avoir les WE, remplace le <6 par >=6

Je te laisse tester

@+

Edit : Coucou Mireille :) Bises

@+
 

Tibo

XLDnaute Barbatruc
Re : jours ouvrés week end et somme prod

Bonjour,

Pour commencer, je te propose une petite simplification pour les cellules en colonnes B et C de l'onglet feuille de calcul

en B2 :

Code:
=SI(NB.SI($D2:$AA2;1)>0;'données à coller et modifier'!N2;0)
en C2 :

Code:
=SI(NB.SI($D2:$AA2;1)>0;'données à coller et modifier'!O2;0)
à recopier vers le bas

Sur l'onglet totalisateur, sur la base de ce qui t'a été proposé hier :

en D3, pour les we :

Code:
=SOMMEPROD((('feuille de cacul'!$B$2:$B$4=$A$2)*(JOURSEM('feuille de cacul'!
$C$2:$C$4=$A$2)[COLOR=Red][B]>=[/B][/COLOR]6)*('feuille de cacul'!D$2:D$4=1)))
en D4, pour les jours ouvrés :

Code:
=SOMMEPROD((('feuille de cacul'!$B$2:$B$4=$A$2)*(JOURSEM('feuille de cacul'!
$C$2:$C$4=$A$2)[B][COLOR=Red]<[/COLOR][/B]6)*('feuille de cacul'!D$2:D$4=1)))

Je te laisse tester

@+
 

Discussions similaires

Réponses
5
Affichages
158
Réponses
7
Affichages
537

Statistiques des forums

Discussions
299 930
Messages
1 980 158
Membres
207 010
dernier inscrit
Setry