XL 2016 Formule matricielle à 2 conditions

Sabrhm

XLDnaute Junior
Bonjour à tous,

Je souhaiterais avoir une formule matricielle comme ci-dessous mais qui remplit 2 conditions : OK (comme ci-dessous) et En-stock (à ajouter).

Est-ce possible ? Merci d'avance.

Cordialement

=SIERREUR(INDEX($AD:$AD;PETITE.VALEUR(SI($AE$27:$AE$43="OK";LIGNE($AE$27:$AE$43);"");LIGNE(A1)));"")
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Sans fichier exemple, difficile d'apporter des solutions.
Peut être:
Code:
=SIERREUR(INDEX($AD:$AD;PETITE.VALEUR(SI(OU($AE$27:$AE$43="OK";$AE$27:$AE$43="En-Stock");LIGNE($AE$27:$AE$43);"");LIGNE(A1)));"")

JHA
 

Sabrhm

XLDnaute Junior
Bonjour à tous,

Sans fichier exemple, difficile d'apporter des solutions.
Peut être:
Code:
=SIERREUR(INDEX($AD:$AD;PETITE.VALEUR(SI(OU($AE$27:$AE$43="OK";$AE$27:$AE$43="En-Stock");LIGNE($AE$27:$AE$43);"");LIGNE(A1)));"")

JHA

Bonjour JHA,

Merci pour votre réponse. Je vois le fonctionnement de la formule mais pour une raison inconnue avec un OU ça marche parfaitement mais quand je remplace OU par ET plus rien ne va.

Avez vous une explication?
 

Sabrhm

XLDnaute Junior
hello sabhm
Alors je suis certain que le ET ne fonctionne pas en matriciel.
Tu dois écrire si((condition1)*(condition2);...)
ou si(condition1;si(condition2;.....))
Cordialement


Merci pour ta rapidité Dugenou.

J'ai essayé de faire avec la méthode que tu m'as donné ci-dessous mais ça coince, il ne m'affiche pas les valeurs souhaitées. Je te joins un exemple.
 

Pièces jointes

  • exemple.xlsx
    18 KB · Affichages: 49

Discussions similaires

Statistiques des forums

Discussions
312 799
Messages
2 092 241
Membres
105 300
dernier inscrit
DJSONO